summaryrefslogtreecommitdiffstats
path: root/third_party/rust/half/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/half/Cargo.toml')
-rw-r--r--third_party/rust/half/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/third_party/rust/half/Cargo.toml b/third_party/rust/half/Cargo.toml
new file mode 100644
index 0000000000..588748bb95
--- /dev/null
+++ b/third_party/rust/half/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "half"
+version = "1.8.2"
+authors = ["Kathryn Long <squeeself@gmail.com>"]
+exclude = [".git*", ".editorconfig"]
+description = "Half-precision floating point f16 and bf16 types for Rust implementing the IEEE 754-2008 standard binary16 and bfloat16 types."
+readme = "README.md"
+keywords = ["f16", "bfloat16", "no_std"]
+categories = ["no-std", "data-structures", "encoding"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/starkat99/half-rs"
+[package.metadata.docs.rs]
+features = ["std", "serde", "bytemuck", "num-traits", "zerocopy"]
+rustc-args = ["--cfg", "docsrs"]
+
+[[bench]]
+name = "convert"
+harness = false
+[dependencies.bytemuck]
+version = "1.4.1"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.num-traits]
+version = "0.2.14"
+features = ["libm"]
+optional = true
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.zerocopy]
+version = "0.6.0"
+optional = true
+default-features = false
+[dev-dependencies.criterion]
+version = "0.3.5"
+
+[dev-dependencies.quickcheck]
+version = "1.0"
+
+[dev-dependencies.quickcheck_macros]
+version = "1.0"
+
+[dev-dependencies.rand]
+version = "0.8.4"
+
+[features]
+alloc = []
+serialize = ["serde"]
+std = ["alloc"]
+use-intrinsics = []