summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-common/Cargo.toml')
-rw-r--r--third_party/rust/neqo-common/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/third_party/rust/neqo-common/Cargo.toml b/third_party/rust/neqo-common/Cargo.toml
new file mode 100644
index 0000000000..f85e6609fc
--- /dev/null
+++ b/third_party/rust/neqo-common/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "neqo-common"
+version = "0.6.3"
+authors = ["Bobby Holley <bobbyholley@gmail.com>"]
+edition = "2018"
+rust-version = "1.57.0"
+license = "MIT/Apache-2.0"
+build = "build.rs"
+
+[dependencies]
+log = {version = "0.4.0", default-features = false}
+env_logger = {version = "0.9", default-features = false}
+lazy_static = "1.3.0"
+qlog = "0.4.0"
+chrono = {version = "0.4.10", default-features = false, features = ["std"]}
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["timeapi"]