summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-http3/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-http3/Cargo.toml')
-rw-r--r--third_party/rust/neqo-http3/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/rust/neqo-http3/Cargo.toml b/third_party/rust/neqo-http3/Cargo.toml
new file mode 100644
index 0000000000..294d0c5c25
--- /dev/null
+++ b/third_party/rust/neqo-http3/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "neqo-http3"
+version = "0.6.3"
+authors = ["Dragana Damjanovic <dragana.damjano@gmail.com>"]
+edition = "2018"
+rust-version = "1.57.0"
+license = "MIT/Apache-2.0"
+
+[dependencies]
+neqo-common = { path = "./../neqo-common" }
+neqo-crypto = { path = "./../neqo-crypto" }
+neqo-transport = { path = "./../neqo-transport" }
+neqo-qpack = { path = "./../neqo-qpack" }
+log = {version = "0.4.0", default-features = false}
+smallvec = "1.0.0"
+qlog = "0.4.0"
+sfv = "0.9.1"
+url = "2.0"
+lazy_static = "1.3.0"
+enumset = "1.0.8"
+
+[dev-dependencies]
+test-fixture = { path = "../test-fixture" }
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []
+fuzzing = ["neqo-transport/fuzzing", "neqo-crypto/fuzzing"]