summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ohttp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ohttp/Cargo.toml')
-rw-r--r--third_party/rust/ohttp/Cargo.toml108
1 files changed, 108 insertions, 0 deletions
diff --git a/third_party/rust/ohttp/Cargo.toml b/third_party/rust/ohttp/Cargo.toml
new file mode 100644
index 0000000000..ee244ba262
--- /dev/null
+++ b/third_party/rust/ohttp/Cargo.toml
@@ -0,0 +1,108 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "ohttp"
+version = "0.2.3"
+authors = ["Martin Thomson <mt@lowentropy.net>"]
+build = "build.rs"
+description = "Oblivious HTTP (draft-ietf-ohai-ohttp)"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/martinthomson/ohttp"
+
+[dependencies.aead]
+version = "0.4"
+features = ["std"]
+optional = true
+
+[dependencies.aes-gcm]
+version = "0.9"
+optional = true
+
+[dependencies.byteorder]
+version = "1.3"
+
+[dependencies.chacha20poly1305]
+version = "0.8"
+optional = true
+
+[dependencies.hex]
+version = "0.4"
+
+[dependencies.hkdf]
+version = "0.11"
+optional = true
+
+[dependencies.hpke]
+version = "0.7"
+features = ["std"]
+optional = true
+default-features = false
+
+[dependencies.lazy_static]
+version = "1.4"
+
+[dependencies.log]
+version = "0.4.0"
+default-features = false
+
+[dependencies.rand]
+version = "0.8"
+optional = true
+
+[dependencies.sha2]
+version = "0.9"
+optional = true
+
+[dev-dependencies.env_logger]
+version = "0.9"
+default-features = false
+
+[build-dependencies.bindgen]
+version = "0.63"
+features = ["runtime"]
+optional = true
+default-features = false
+
+[build-dependencies.mozbuild]
+version = "0.1"
+optional = true
+
+[build-dependencies.serde]
+version = "1.0"
+
+[build-dependencies.serde_derive]
+version = "1.0"
+
+[build-dependencies.toml]
+version = "0.5"
+
+[features]
+client = []
+default = [
+ "client",
+ "server",
+ "rust-hpke",
+]
+gecko = ["mozbuild"]
+nss = ["bindgen"]
+rust-hpke = [
+ "hpke/x25519",
+ "rand",
+ "aead",
+ "aes-gcm",
+ "chacha20poly1305",
+ "hkdf",
+ "sha2",
+]
+server = []