summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rust_cascade/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/rust_cascade/Cargo.toml')
-rw-r--r--third_party/rust/rust_cascade/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/rust/rust_cascade/Cargo.toml b/third_party/rust/rust_cascade/Cargo.toml
new file mode 100644
index 0000000000..a33da9b4c1
--- /dev/null
+++ b/third_party/rust/rust_cascade/Cargo.toml
@@ -0,0 +1,34 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "rust_cascade"
+version = "1.4.0"
+authors = ["Mark Goodwin <mgoodwin@mozilla.com>", "Dana Keeler <dkeeler@mozilla.com>", "J.C. Jones <jc@mozilla.com>", "John Schanck <jschanck@mozilla.com>"]
+description = "A simple bloom filter cascade implementation in Rust."
+homepage = "https://github.com/mozilla/rust-cascade"
+documentation = "https://docs.rs/rust_cascade/"
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/rust-cascade"
+[dependencies.byteorder]
+version = "1.3.1"
+
+[dependencies.murmurhash3]
+version = "0.0.5"
+
+[dependencies.rand]
+version = "0.7.3"
+
+[dependencies.sha2]
+version = "0.10.2"
+
+[features]
+builder = []