summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde_repr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/serde_repr/Cargo.toml')
-rw-r--r--third_party/rust/serde_repr/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/third_party/rust/serde_repr/Cargo.toml b/third_party/rust/serde_repr/Cargo.toml
new file mode 100644
index 0000000000..d1a4916e0a
--- /dev/null
+++ b/third_party/rust/serde_repr/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.31"
+name = "serde_repr"
+version = "0.1.10"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "Derive Serialize and Deserialize that delegates to the underlying repr of a C-like enum."
+documentation = "https://docs.rs/serde_repr"
+readme = "README.md"
+keywords = [
+ "serde",
+ "serialization",
+ "integer",
+]
+categories = [
+ "encoding",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/serde-repr"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0"
+
+[dev-dependencies.rustversion]
+version = "1.0"
+
+[dev-dependencies.serde]
+version = "1.0"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.trybuild]
+version = "1.0.49"
+features = ["diff"]