summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tokio-macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/tokio-macros/Cargo.toml')
-rw-r--r--third_party/rust/tokio-macros/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/third_party/rust/tokio-macros/Cargo.toml b/third_party/rust/tokio-macros/Cargo.toml
new file mode 100644
index 0000000000..04bfa41ef1
--- /dev/null
+++ b/third_party/rust/tokio-macros/Cargo.toml
@@ -0,0 +1,47 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.49"
+name = "tokio-macros"
+version = "1.8.2"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = """
+Tokio's proc macros.
+"""
+homepage = "https://tokio.rs"
+readme = "README.md"
+categories = ["asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0.7"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "1.0.56"
+features = ["full"]
+
+[dev-dependencies.tokio]
+version = "1.0.0"
+features = ["full"]
+
+[features]