summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wgpu-core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/wgpu-core/Cargo.toml')
-rw-r--r--third_party/rust/wgpu-core/Cargo.toml84
1 files changed, 84 insertions, 0 deletions
diff --git a/third_party/rust/wgpu-core/Cargo.toml b/third_party/rust/wgpu-core/Cargo.toml
new file mode 100644
index 0000000000..bc2c212fc7
--- /dev/null
+++ b/third_party/rust/wgpu-core/Cargo.toml
@@ -0,0 +1,84 @@
+[package]
+name = "wgpu-core"
+version = "0.14.0"
+authors = ["wgpu developers"]
+edition = "2021"
+description = "WebGPU core logic on wgpu-hal"
+homepage = "https://wgpu.rs/"
+repository = "https://github.com/gfx-rs/wgpu"
+keywords = ["graphics"]
+license = "MIT OR Apache-2.0"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[lib]
+
+[features]
+default = []
+
+# Backends, passed through to wgpu-hal
+metal = ["hal/metal"]
+vulkan = ["hal/vulkan"]
+gles = ["hal/gles"]
+dx11 = ["hal/dx11"]
+dx12 = ["hal/dx12"]
+
+# Support the Renderdoc graphics debugger:
+# https://renderdoc.org/
+renderdoc = ["hal/renderdoc"]
+
+# Compile for the Emscripten POSIX-in-a-web-page emulation environment.
+emscripten = ["hal/emscripten"]
+
+# Apply run-time checks, even in release builds. These are in addition
+# to the validation carried out at public APIs in all builds.
+strict_asserts = ["wgt/strict_asserts"]
+angle = ["hal/gles"]
+# Enable API tracing
+trace = ["ron", "serde", "wgt/trace", "arrayvec/serde", "naga/serialize"]
+# Enable API replaying
+replay = ["serde", "wgt/replay", "arrayvec/serde", "naga/deserialize"]
+# Enable serializable compute/render passes, and bundle encoders.
+serial-pass = ["serde", "wgt/serde", "arrayvec/serde"]
+id32 = []
+# Enable `ShaderModuleSource::Wgsl`
+wgsl = ["naga/wgsl-in"]
+vulkan-portability = ["hal/vulkan"]
+
+# Features that are intended to work on all platforms.
+portable_features = ["gles", "strict_asserts", "trace", "replay", "serial-pass", "id32", "wgsl"]
+
+[dependencies]
+arrayvec = "0.7"
+bitflags = "1"
+bit-vec = "0.6"
+codespan-reporting = "0.11"
+fxhash = "0.2.1"
+log = "0.4"
+# parking_lot 0.12 switches from `winapi` to `windows`; permit either
+parking_lot = ">=0.11,<0.13"
+profiling = { version = "1", default-features = false }
+raw-window-handle = { version = "0.5", optional = true }
+ron = { version = "0.8", optional = true }
+serde = { version = "1", features = ["serde_derive"], optional = true }
+smallvec = "1"
+thiserror = "1"
+
+[dependencies.naga]
+git = "https://github.com/gfx-rs/naga"
+rev = "e7fc8e6"
+version = "0.10"
+features = ["clone", "span", "validate"]
+
+[dependencies.wgt]
+package = "wgpu-types"
+path = "../wgpu-types"
+
+[dependencies.hal]
+package = "wgpu-hal"
+path = "../wgpu-hal"
+
+[target.'cfg(all(target_arch = "wasm32", not(target_os = "emscripten")))'.dependencies]
+web-sys = { version = "0.3.60", features = ["HtmlCanvasElement", "OffscreenCanvas"] }