summaryrefslogtreecommitdiffstats
path: root/pam_gdm/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:43:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:43:08 +0000
commitd524c8e88f558b9f2aebff39b6fbe77eab51e081 (patch)
tree399d1caf80df6656549115df912f6af2f7369308 /pam_gdm/meson.build
parentInitial commit. (diff)
downloadgdm3-upstream.tar.xz
gdm3-upstream.zip
Adding upstream version 43.0.upstream/43.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pam_gdm/meson.build')
-rw-r--r--pam_gdm/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/pam_gdm/meson.build b/pam_gdm/meson.build
new file mode 100644
index 0000000..f47d8e6
--- /dev/null
+++ b/pam_gdm/meson.build
@@ -0,0 +1,16 @@
+pam_gdm_deps = [
+ libpam_dep,
+]
+
+if keyutils_dep.found()
+ pam_gdm_deps += keyutils_dep
+endif
+
+pam_gdm = library('pam_gdm',
+ 'pam_gdm.c',
+ dependencies: pam_gdm_deps,
+ include_directories: config_h_dir,
+ name_prefix: '',
+ install: true,
+ install_dir: pam_mod_dir,
+)