summaryrefslogtreecommitdiffstats
path: root/data/autostart/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/autostart/meson.build')
-rw-r--r--data/autostart/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/data/autostart/meson.build b/data/autostart/meson.build
new file mode 100644
index 0000000..348a6c6
--- /dev/null
+++ b/data/autostart/meson.build
@@ -0,0 +1,12 @@
+autostart_files_conf = {
+ 'LIBEXECDIR': gdm_prefix / get_option('libexecdir'),
+}
+
+foreach autostart_file : [ 'orca-autostart.desktop' ]
+ configure_file(
+ input: autostart_file,
+ output: autostart_file,
+ configuration: autostart_files_conf,
+ install_dir: get_option('datadir') / 'gdm' / 'greeter' / 'autostart',
+ )
+endforeach