summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..128b5d2
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,17 @@
+m_common_test_src = [
+ 'm-common.c',
+ 's-common-address.c',
+ 's-common.c',
+]
+
+m_common_test_deps = [
+ libgdmcommon_dep,
+ libcheck_dep,
+]
+
+m_common_test = executable('m-common',
+ m_common_test_src,
+ dependencies: m_common_test_deps,
+)
+
+test('m-common', m_common_test)