summaryrefslogtreecommitdiffstats
path: root/plugins/quickhighlight/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 17:42:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 17:42:51 +0000
commitba429d344132c088177e853cce8ff7181570b221 (patch)
tree87ebf15269b4301737abd1735baabba71be93622 /plugins/quickhighlight/meson.build
parentInitial commit. (diff)
downloadgedit-upstream.tar.xz
gedit-upstream.zip
Adding upstream version 44.2.upstream/44.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plugins/quickhighlight/meson.build')
-rw-r--r--plugins/quickhighlight/meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/plugins/quickhighlight/meson.build b/plugins/quickhighlight/meson.build
new file mode 100644
index 0000000..18fb417
--- /dev/null
+++ b/plugins/quickhighlight/meson.build
@@ -0,0 +1,32 @@
+libquickhighlight_sources = files(
+ 'gedit-quick-highlight-plugin.c',
+)
+
+libquickhighlight_deps = [
+ libgedit_dep,
+]
+
+libquickhighlight_sha = shared_module(
+ 'quickhighlight',
+ sources: libquickhighlight_sources,
+ include_directories: root_include_dir,
+ dependencies: libquickhighlight_deps,
+ install: true,
+ install_dir: join_paths(
+ pkglibdir,
+ 'plugins',
+ ),
+ name_suffix: module_suffix,
+)
+
+custom_target(
+ 'quickhighlight.plugin',
+ input: 'quickhighlight.plugin.desktop.in',
+ output: 'quickhighlight.plugin',
+ command: msgfmt_plugin_cmd,
+ install: true,
+ install_dir: join_paths(
+ pkglibdir,
+ 'plugins',
+ )
+)