summaryrefslogtreecommitdiffstats
path: root/plugins/filebrowser/resources
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/filebrowser/resources')
-rw-r--r--plugins/filebrowser/resources/gedit-file-browser.gresource.xml7
-rw-r--r--plugins/filebrowser/resources/meson.build8
-rw-r--r--plugins/filebrowser/resources/ui/gedit-file-browser-menus.ui84
-rw-r--r--plugins/filebrowser/resources/ui/gedit-file-browser-widget.ui275
4 files changed, 374 insertions, 0 deletions
diff --git a/plugins/filebrowser/resources/gedit-file-browser.gresource.xml b/plugins/filebrowser/resources/gedit-file-browser.gresource.xml
new file mode 100644
index 0000000..273bd26
--- /dev/null
+++ b/plugins/filebrowser/resources/gedit-file-browser.gresource.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<gresources>
+ <gresource prefix="/org/gnome/gedit/plugins/file-browser">
+ <file preprocess="xml-stripblanks">ui/gedit-file-browser-menus.ui</file>
+ <file preprocess="xml-stripblanks">ui/gedit-file-browser-widget.ui</file>
+ </gresource>
+</gresources>
diff --git a/plugins/filebrowser/resources/meson.build b/plugins/filebrowser/resources/meson.build
new file mode 100644
index 0000000..da2b577
--- /dev/null
+++ b/plugins/filebrowser/resources/meson.build
@@ -0,0 +1,8 @@
+libfilebrowser_res = gnome.compile_resources(
+ 'gedit-file-browser-resources',
+ 'gedit-file-browser.gresource.xml',
+)
+
+libfilebrowser_sources += [
+ libfilebrowser_res.get(0),
+]
diff --git a/plugins/filebrowser/resources/ui/gedit-file-browser-menus.ui b/plugins/filebrowser/resources/ui/gedit-file-browser-menus.ui
new file mode 100644
index 0000000..9134268
--- /dev/null
+++ b/plugins/filebrowser/resources/ui/gedit-file-browser-menus.ui
@@ -0,0 +1,84 @@
+<?xml version="1.0"?>
+<interface>
+ <!-- interface-requires gtk+ 3.0 -->
+ <menu id="dir-menu">
+ <section>
+ <item>
+ <attribute name="label" translatable="yes">_Open</attribute>
+ <attribute name="action">browser.open</attribute>
+ </item>
+ </section>
+ <section>
+ <item>
+ <attribute name="label" translatable="yes">_Set Root to Active Document</attribute>
+ <attribute name="action">browser.set_active_root</attribute>
+ </item>
+ </section>
+ <section>
+ <item>
+ <attribute name="label" translatable="yes">_New Folder</attribute>
+ <attribute name="action">browser.new_folder</attribute>
+ </item>
+ <item>
+ <attribute name="label" translatable="yes">New F_ile</attribute>
+ <attribute name="action">browser.new_file</attribute>
+ </item>
+ </section>
+ <section>
+ <item>
+ <attribute name="label" translatable="yes">_Rename…</attribute>
+ <attribute name="action">browser.rename</attribute>
+ </item>
+ <item>
+ <attribute name="label" translatable="yes">_Move to Trash</attribute>
+ <attribute name="action">browser.move_to_trash</attribute>
+ </item>
+ <item>
+ <attribute name="label" translatable="yes">_Delete</attribute>
+ <attribute name="action">browser.delete</attribute>
+ </item>
+ </section>
+ <section>
+ <item>
+ <attribute name="label" translatable="yes">Re_fresh View</attribute>
+ <attribute name="action">browser.refresh_view</attribute>
+ </item>
+ <item>
+ <attribute name="label" translatable="yes">_View Folder</attribute>
+ <attribute name="action">browser.view_folder</attribute>
+ </item>
+ <item>
+ <attribute name="label" translatable="yes">_Open in Terminal</attribute>
+ <attribute name="action">browser.open_in_terminal</attribute>
+ </item>
+ </section>
+ <submenu>
+ <attribute name="label" translatable="yes">_Filter</attribute>
+ <section>
+ <item>
+ <attribute name="label" translatable="yes">Show _Hidden</attribute>
+ <attribute name="action">browser.show_hidden</attribute>
+ </item>
+ <item>
+ <attribute name="label" translatable="yes">Show _Binary</attribute>
+ <attribute name="action">browser.show_binary</attribute>
+ </item>
+ <item>
+ <attribute name="label" translatable="yes">Match Filename</attribute>
+ <attribute name="action">browser.show_match_filename</attribute>
+ </item>
+ </section>
+ </submenu>
+ <section>
+ <attribute name="id">extension-section</attribute>
+ </section>
+ </menu>
+ <menu id="bookmarks-menu">
+ <section>
+ <item>
+ <attribute name="label" translatable="yes">_Set Root to Active Document</attribute>
+ <attribute name="action">browser.set_active_root</attribute>
+ </item>
+ </section>
+ </menu>
+</interface>
diff --git a/plugins/filebrowser/resources/ui/gedit-file-browser-widget.ui b/plugins/filebrowser/resources/ui/gedit-file-browser-widget.ui
new file mode 100644
index 0000000..e4fb300
--- /dev/null
+++ b/plugins/filebrowser/resources/ui/gedit-file-browser-widget.ui
@@ -0,0 +1,275 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<interface>
+ <!-- interface-requires gtk+ 3.6 -->
+ <object class="GtkListStore" id="locations_model">
+ <columns>
+ <!-- column-name icon -->
+ <column type="GdkPixbuf"/>
+ <!-- column-name icon name -->
+ <column type="gchararray"/>
+ <!-- column-name name -->
+ <column type="gchararray"/>
+ <!-- column-name file -->
+ <column type="GFile"/>
+ <!-- column-name id -->
+ <column type="guint"/>
+ </columns>
+ </object>
+ <object class="GtkPopover" id="locations_popover">
+ <property name="can_focus">True</property>
+ <property name="visible">True</property>
+ <property name="width-request">300</property>
+ <property name="height-request">300</property>
+ <child>
+ <object class="GtkScrolledWindow" id="locations_scrolledwindow">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="shadow_type">in</property>
+ <property name="margin">6</property>
+ <property name="hscrollbar_policy">never</property>
+ <property name="hexpand">True</property>
+ <property name="vexpand">True</property>
+ <child>
+ <object class="GtkTreeView" id="locations_treeview">
+ <property name="visible">True</property>
+ <property name="headers_visible">False</property>
+ <property name="can_focus">True</property>
+ <property name="model">locations_model</property>
+ <property name="activate-on-single-click">True</property>
+ <child>
+ <object class="GtkTreeViewColumn" id="treeview_icon_column">
+ <child>
+ <object class="GtkCellRendererPixbuf" id="treeview_icon_renderer"/>
+ </child>
+ </object>
+ </child>
+ <child>
+ <object class="GtkTreeViewColumn" id="treeview_name_column">
+ <child>
+ <object class="GtkCellRendererText" id="treeview_name_renderer">
+ <property name="ellipsize">end</property>
+ </object>
+ <attributes>
+ <attribute name="text">2</attribute>
+ </attributes>
+ </child>
+ </object>
+ </child>
+ <child internal-child="selection">
+ <object class="GtkTreeSelection" id="locations_treeview_selection"/>
+ </child>
+ </object>
+ </child>
+ </object>
+ </child>
+ </object>
+ <object class="GtkMenu" id="location_previous_menu">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ </object>
+ <object class="GtkMenu" id="location_next_menu">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ </object>
+ <template class="GeditFileBrowserWidget" parent="GtkGrid">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <child>
+ <object class="GtkBox" id="toolbar">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="margin">3</property>
+ <property name="spacing">3</property>
+ <child>
+ <object class="GtkBox" id="box1">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <child>
+ <object class="GtkButton" id="previous_button">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+ <property name="action_name">browser.previous_location</property>
+ <property name="image">previous_image</property>
+ <style>
+ <class name="small-button"/>
+ </style>
+ </object>
+ </child>
+ <child>
+ <object class="GtkButton" id="next_button">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+ <property name="action_name">browser.next_location</property>
+ <property name="image">next_image</property>
+ <style>
+ <class name="small-button"/>
+ </style>
+ </object>
+ </child>
+ <style>
+ <class name="linked"/>
+ </style>
+ </object>
+ </child>
+ <child>
+ <object class="GtkButton" id="button3">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+ <property name="action_name">browser.up</property>
+ <property name="image">up_image</property>
+ <style>
+ <class name="small-button"/>
+ </style>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkMenuButton" id="locations_button">
+ <property name="visible">True</property>
+ <property name="valign">center</property>
+ <property name="use_popover">True</property>
+ <property name="popover">locations_popover</property>
+ <style>
+ <class name="text-button"/>
+ <class name="image-button"/>
+ <class name="small-button"/>
+ </style>
+ <child>
+ <object class="GtkBox" id="locations_button_box">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="has_focus">False</property>
+ <property name="is_focus">False</property>
+ <property name="spacing">6</property>
+ <child>
+ <object class="GtkCellView" id="locations_cellview">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="model">locations_model</property>
+ <child>
+ <object class="GtkCellRendererPixbuf" id="cellview_icon_renderer"/>
+ </child>
+ <child>
+ <object class="GtkCellRendererText" id="cellview_name_renderer">
+ <property name="ellipsize">end</property>
+ </object>
+ <attributes>
+ <attribute name="text">2</attribute>
+ </attributes>
+ </child>
+ </object>
+ </child>
+ <child>
+ <object class="GtkImage" id="locations_button_arrow">
+ <property name="visible">True</property>
+ <property name="valign">baseline</property>
+ <property name="icon_name">pan-down-symbolic</property>
+ </object>
+ <packing>
+ <property name="pack-type">GTK_PACK_END</property>
+ </packing>
+ </child>
+ </object>
+ </child>
+ <child internal-child="accessible">
+ <object class="AtkObject" id="locations_button_a11y">
+ <property name="accessible-name" translatable="yes">History</property>
+ <property name="accessible-description" translatable="yes">Open history menu</property>
+ </object>
+ </child>
+ </object>
+ <packing>
+ <property name="expand">True</property>
+ </packing>
+ </child>
+ </object>
+ <packing>
+ <property name="left_attach">0</property>
+ <property name="top_attach">0</property>
+ <property name="width">1</property>
+ <property name="height">1</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkSearchEntry" id="location_entry">
+ <property name="visible">False</property>
+ <property name="can_focus">True</property>
+ <property name="invisible_char">●</property>
+ <property name="primary_icon_name">folder-symbolic</property>
+ </object>
+ <packing>
+ <property name="left_attach">0</property>
+ <property name="top_attach">1</property>
+ <property name="width">1</property>
+ <property name="height">1</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkScrolledWindow" id="scrolledwindow1">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="hexpand">True</property>
+ <property name="vexpand">True</property>
+ <child>
+ <object class="GeditFileBrowserView" id="treeview">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <child internal-child="selection">
+ <object class="GtkTreeSelection" id="treeview-selection1"/>
+ </child>
+ </object>
+ </child>
+ </object>
+ <packing>
+ <property name="left_attach">0</property>
+ <property name="top_attach">3</property>
+ <property name="width">1</property>
+ <property name="height">1</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkRevealer" id="filter_entry_revealer">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+ <property name="reveal_child">False</property>
+ <property name="valign">start</property>
+ <child>
+ <object class="GtkEntry" id="filter_entry">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="invisible_char">●</property>
+ <property name="placeholder_text">Match Filename</property>
+ </object>
+ </child>
+ </object>
+ <packing>
+ <property name="left_attach">0</property>
+ <property name="top_attach">4</property>
+ <property name="width">1</property>
+ <property name="height">1</property>
+ </packing>
+ </child>
+ </template>
+ <object class="GtkImage" id="previous_image">
+ <property name="visible">True</property>
+ <property name="icon_name">go-previous-symbolic</property>
+ <property name="icon-size">2</property>
+ </object>
+ <object class="GtkImage" id="next_image">
+ <property name="visible">True</property>
+ <property name="icon_name">go-next-symbolic</property>
+ <property name="icon-size">2</property>
+ </object>
+ <object class="GtkImage" id="up_image">
+ <property name="visible">True</property>
+ <property name="icon_name">go-up-symbolic</property>
+ <property name="icon-size">2</property>
+ </object>
+</interface>