summaryrefslogtreecommitdiffstats
path: root/plugins/pythonconsole/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/pythonconsole/meson.build')
-rw-r--r--plugins/pythonconsole/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/plugins/pythonconsole/meson.build b/plugins/pythonconsole/meson.build
new file mode 100644
index 0000000..1aecada
--- /dev/null
+++ b/plugins/pythonconsole/meson.build
@@ -0,0 +1,31 @@
+subdir('pythonconsole')
+
+pythonconsole_gschema_file = files('org.gnome.gedit.plugins.pythonconsole.gschema.xml')
+install_data(
+ pythonconsole_gschema_file,
+ install_dir: join_paths(get_option('prefix'), get_option('datadir'), 'glib-2.0/schemas')
+)
+
+if xmllint.found()
+ test(
+ 'validate-pythonconsole-gschema',
+ xmllint,
+ args: [
+ '--noout',
+ '--dtdvalid', gschema_dtd,
+ pythonconsole_gschema_file,
+ ]
+ )
+endif
+
+custom_target(
+ 'pythonconsole.plugin',
+ input: 'pythonconsole.plugin.desktop.in',
+ output: 'pythonconsole.plugin',
+ command: msgfmt_plugin_cmd,
+ install: true,
+ install_dir: join_paths(
+ pkglibdir,
+ 'plugins',
+ )
+)