summaryrefslogtreecommitdiffstats
path: root/plugins/pythonconsole/pythonconsole/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/pythonconsole/pythonconsole/meson.build')
-rw-r--r--plugins/pythonconsole/pythonconsole/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/plugins/pythonconsole/pythonconsole/meson.build b/plugins/pythonconsole/pythonconsole/meson.build
new file mode 100644
index 0000000..6bae388
--- /dev/null
+++ b/plugins/pythonconsole/pythonconsole/meson.build
@@ -0,0 +1,24 @@
+pythonconsole_sources = files(
+ '__init__.py',
+ 'config.py',
+ 'console.py',
+)
+
+install_data(
+ pythonconsole_sources,
+ install_dir: join_paths(
+ pkglibdir,
+ 'plugins',
+ 'pythonconsole',
+ )
+)
+
+install_data(
+ 'config.ui',
+ install_dir: join_paths(
+ pkgdatadir,
+ 'plugins',
+ 'pythonconsole',
+ 'ui',
+ )
+)