summaryrefslogtreecommitdiffstats
path: root/subprojects/libgd/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/libgd/meson.build')
-rw-r--r--subprojects/libgd/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/subprojects/libgd/meson.build b/subprojects/libgd/meson.build
new file mode 100644
index 0000000..6d1242c
--- /dev/null
+++ b/subprojects/libgd/meson.build
@@ -0,0 +1,24 @@
+project('libgd', 'c',
+ meson_version: '>= 0.38.0',
+ default_options: ['static=true'],
+)
+
+if not meson.is_subproject()
+ message('WARNING: This project is only intended to be used as a subproject!')
+endif
+
+pkglibdir = get_option('pkglibdir')
+pkgdatadir = get_option('pkgdatadir')
+
+libgtk = dependency('gtk+-3.0', version: '>= 3.7.10')
+cc = meson.get_compiler('c')
+libm = cc.find_library('m', required: false)
+libgd_include = include_directories('.')
+
+subdir('libgd')
+
+if get_option('with-tagged-entry')
+ foreach t : ['test-tagged-entry', 'test-tagged-entry-2']
+ executable(t, t + '.c', dependencies : libgd_dep)
+ endforeach
+endif