summaryrefslogtreecommitdiffstats
path: root/devel-docs/libgimpmodule/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
commit5c1676dfe6d2f3c837a5e074117b45613fd29a72 (patch)
treecbffb45144febf451e54061db2b21395faf94bfe /devel-docs/libgimpmodule/Makefile.am
parentInitial commit. (diff)
downloadgimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.tar.xz
gimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.zip
Adding upstream version 2.10.34.upstream/2.10.34upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'devel-docs/libgimpmodule/Makefile.am')
-rw-r--r--devel-docs/libgimpmodule/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/devel-docs/libgimpmodule/Makefile.am b/devel-docs/libgimpmodule/Makefile.am
new file mode 100644
index 0000000..602eab5
--- /dev/null
+++ b/devel-docs/libgimpmodule/Makefile.am
@@ -0,0 +1,58 @@
+## Process this file with automake to produce Makefile.in
+
+# The name of the module.
+DOC_MODULE = libgimpmodule
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE = $(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code.
+DOC_SOURCE_DIR = $(top_srcdir)/$(DOC_MODULE)
+
+# Extra options to pass to gtkdoc-scangobj
+SCANGOBJ_OPTIONS =
+
+# Extra options to supply to gtkdoc-scan
+SCAN_OPTIONS = --deprecated-guards="GIMP_DISABLE_DEPRECATED"
+
+# Extra options to supply to gtkdoc-mkdb
+MKDB_OPTIONS = --sgml-mode --output-format=xml --name-space=gimp
+
+# Extra options to supply to gtkdoc-fixref
+FIXXREF_OPTIONS =
+
+# Used for dependencies
+HFILE_GLOB = $(DOC_SOURCE_DIR)/*.h
+CFILE_GLOB = $(DOC_SOURCE_DIR)/*.c
+
+# Header files to ignore when scanning
+IGNORE_HFILES =
+
+# Images to copy into HTML directory
+HTML_IMAGES=
+
+# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE)
+content_files =
+
+# Other files to distribute
+extra_files =
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+GTKDOC_CFLAGS = \
+ @CFLAGS@ \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ @GLIB_CFLAGS@ \
+ @GMODULE_NO_EXPORT_CFLAGS@
+
+GTKDOC_LIBS = \
+ $(top_builddir)/libgimpmodule/libgimpmodule-$(GIMP_API_VERSION).la \
+ @GLIB_LIBS@ \
+ @GMODULE_NO_EXPORT_LIBS@
+
+
+include $(top_srcdir)/gtk-doc.make
+
+# Other files to distribute
+EXTRA_DIST += version.in