summaryrefslogtreecommitdiffstats
path: root/devel-docs/tools/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
commit5c1676dfe6d2f3c837a5e074117b45613fd29a72 (patch)
treecbffb45144febf451e54061db2b21395faf94bfe /devel-docs/tools/Makefile.am
parentInitial commit. (diff)
downloadgimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.tar.xz
gimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.zip
Adding upstream version 2.10.34.upstream/2.10.34upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'devel-docs/tools/Makefile.am')
-rw-r--r--devel-docs/tools/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/devel-docs/tools/Makefile.am b/devel-docs/tools/Makefile.am
new file mode 100644
index 0000000..4554852
--- /dev/null
+++ b/devel-docs/tools/Makefile.am
@@ -0,0 +1,56 @@
+## Process this file with automake to produce Makefile.in
+
+if OS_WIN32
+mwindows = -mwindows
+else
+libm = -lm
+endif
+
+libgimpbase = $(top_builddir)/libgimpbase/libgimpbase-$(GIMP_API_VERSION).la
+libgimpcolor = $(top_builddir)/libgimpcolor/libgimpcolor-$(GIMP_API_VERSION).la
+libgimpconfig = $(top_builddir)/libgimpconfig/libgimpconfig-$(GIMP_API_VERSION).la
+libgimpmath = $(top_builddir)/libgimpmath/libgimpmath-$(GIMP_API_VERSION).la $(libm)
+libgimpmodule = $(top_builddir)/libgimpmodule/libgimpmodule-$(GIMP_API_VERSION).la
+libgimpwidgets = $(top_builddir)/libgimpwidgets/libgimpwidgets-$(GIMP_API_VERSION).la
+
+
+AM_CPPFLAGS = \
+ $(GTK_CFLAGS) \
+ -DTOP_SRCDIR=\"$(top_srcdir)\" \
+ -I$(top_srcdir) \
+ $(GEGL_CFLAGS)
+
+AM_LDFLAGS = $(mwindows)
+
+
+if ENABLE_GTK_DOC
+noinst_PROGRAMS = $(DOC_SHOOTER)
+endif
+
+doc_shooter_SOURCES = \
+ shadow.c \
+ shadow.h \
+ shooter.c \
+ units.c \
+ units.h \
+ widgets.c \
+ widgets.h
+
+doc_shooter_LDADD = \
+ $(libgimpwidgets) \
+ $(libgimpconfig) \
+ $(libgimpmodule) \
+ $(libgimpmath) \
+ $(libgimpcolor) \
+ $(libgimpbase) \
+ $(GTK_LIBS) \
+ $(X_LIBS) -lX11 -lXext
+
+
+EXTRA_PROGRAMS = doc-shooter
+
+EXTRA_DIST = README.shooter
+
+
+clean-local:
+ rm -f *.png