summaryrefslogtreecommitdiffstats
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
commit5c1676dfe6d2f3c837a5e074117b45613fd29a72 (patch)
treecbffb45144febf451e54061db2b21395faf94bfe /docs/Makefile.am
parentInitial commit. (diff)
downloadgimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.tar.xz
gimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.zip
Adding upstream version 2.10.34.upstream/2.10.34upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100644
index 0000000..b4e3161
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,55 @@
+## Process this file with automake to produce Makefile.in
+
+EXTRA_DIST = \
+ Wilber.xcf.gz \
+ Wilber.xcf.gz.README \
+ Wilber_Construction_Kit.xcf.gz
+
+mans = \
+ gimp-$(GIMP_APP_VERSION).1 \
+ gimprc-$(GIMP_APP_VERSION).5
+
+man_MANS = \
+ $(mans) \
+ gimptool-$(GIMP_TOOL_VERSION).1
+
+default_binary_mans = $(mans)
+if ENABLE_GIMP_CONSOLE
+default_binary_mans += gimp-console-$(GIMP_APP_VERSION).1
+endif
+
+install-data-hook:
+if ENABLE_GIMP_CONSOLE
+ cd $(DESTDIR)$(mandir)/man1; \
+ rm -f gimp-console-$(GIMP_APP_VERSION).1; \
+ ln -s gimp-$(GIMP_APP_VERSION).1 gimp-console-$(GIMP_APP_VERSION).1
+endif
+if DEFAULT_BINARY
+ @list='$(default_binary_mans)'; \
+ for i in $$list; do \
+ s=`echo $$i | sed -e 's/.*\\(.\\)$$/\1/'`; \
+ n=`echo $$i | sed -e 's/-[^-]*$$//'`; \
+ f="$$n.$$s"; \
+ echo "cd $(DESTDIR)$(mandir)/man$$s"; \
+ cd $(DESTDIR)$(mandir)/man$$s; \
+ echo "rm -f $$f"; \
+ rm -f $$f; \
+ echo "ln -s $$i $$f"; \
+ ln -s $$i $$f; \
+ done
+endif
+
+uninstall-local:
+if ENABLE_GIMP_CONSOLE
+ rm -f $(DESTDIR)$(mandir)/man1/gimp-console-$(GIMP_APP_VERSION).1
+endif
+if DEFAULT_BINARY
+ @list='$(default_binary_mans)'; \
+ for i in $$list; do \
+ s=`echo $$i | sed -e 's/.*\\(.\\)$$/\1/'`; \
+ n=`echo $$i | sed -e 's/-[^-]*$$//'`; \
+ f="$$n.$$s"; \
+ echo " rm -f $(DESTDIR)$(mandir)/man$$s/$$f"; \
+ rm -f $(DESTDIR)$(mandir)/man$$s/$$f; \
+ done
+endif