summaryrefslogtreecommitdiffstats
path: root/plug-ins/gfig/images/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
commit5c1676dfe6d2f3c837a5e074117b45613fd29a72 (patch)
treecbffb45144febf451e54061db2b21395faf94bfe /plug-ins/gfig/images/Makefile.am
parentInitial commit. (diff)
downloadgimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.tar.xz
gimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.zip
Adding upstream version 2.10.34.upstream/2.10.34upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plug-ins/gfig/images/Makefile.am')
-rw-r--r--plug-ins/gfig/images/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/plug-ins/gfig/images/Makefile.am b/plug-ins/gfig/images/Makefile.am
new file mode 100644
index 0000000..093fe5c
--- /dev/null
+++ b/plug-ins/gfig/images/Makefile.am
@@ -0,0 +1,35 @@
+## Process this file with automake to produce Makefile.in
+
+STOCK_IMAGES = \
+ stock-bezier.png \
+ stock-circle.png \
+ stock-copy-object.png \
+ stock-curve.png \
+ stock-delete-object.png \
+ stock-ellipse.png \
+ stock-line.png \
+ stock-move-object.png \
+ stock-move-point.png \
+ stock-polygon.png \
+ stock-rectangle.png \
+ stock-select-object.png \
+ stock-show-all.png \
+ stock-spiral.png \
+ stock-star.png \
+ stock-logo.png
+
+EXTRA_DIST = $(STOCK_IMAGES)
+
+noinst_DATA = gfig-stock-pixbufs.h
+CLEANFILES = $(noinst_DATA) stock-icons.list
+
+stock-icons.list: $(STOCK_IMAGES) Makefile.am
+ ( rm -f $@; \
+ for image in $(STOCK_IMAGES); do \
+ echo $$image | \
+ sed -e 's|.*/||' -e 's|-|_|g' -e 's|\.png$$||' >> $@; \
+ echo " $(srcdir)/$$image" >> $@; \
+ done )
+
+$(srcdir)/gfig-stock-pixbufs.h: stock-icons.list
+ $(GDK_PIXBUF_CSOURCE) --raw --build-list `cat stock-icons.list` > $(@F)