summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:30:19 +0000
commit5c1676dfe6d2f3c837a5e074117b45613fd29a72 (patch)
treecbffb45144febf451e54061db2b21395faf94bfe /tools/Makefile.am
parentInitial commit. (diff)
downloadgimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.tar.xz
gimp-5c1676dfe6d2f3c837a5e074117b45613fd29a72.zip
Adding upstream version 2.10.34.upstream/2.10.34upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am119
1 files changed, 119 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 0000000..420b9b1
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,119 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = subdir-objects
+
+libgimpbase = $(top_builddir)/libgimpbase/libgimpbase-$(GIMP_API_VERSION).la
+
+if PLATFORM_OSX
+xobjective_c = "-xobjective-c"
+xobjective_cxx = "-xobjective-c++"
+xnone = "-xnone"
+endif
+
+bin_PROGRAMS = \
+ gimptool-@GIMP_TOOL_VERSION@ \
+ gimp-test-clipboard-@GIMP_TOOL_VERSION@
+
+if OS_WIN32
+
+bin_PROGRAMS += gimp-debug-resume
+
+gimp_debug_resume_SOURCES = gimp-debug-resume.c
+
+else
+
+libm = -lm
+
+endif
+
+EXTRA_PROGRAMS = \
+ kernelgen
+
+
+gimptool_@GIMP_TOOL_VERSION@_SOURCES = gimptool.c
+
+gimptool_@GIMP_TOOL_VERSION@_LDADD = \
+ $(libgimpbase) \
+ $(GTK_LIBS)
+
+
+gimp_test_clipboard_@GIMP_TOOL_VERSION@_SOURCES = gimp-test-clipboard.c
+
+gimp_test_clipboard_@GIMP_TOOL_VERSION@_LDADD = \
+ $(libgimpbase) \
+ $(GTK_LIBS)
+
+
+kernelgen_SOURCES = kernelgen.c
+
+
+
+if ENABLE_VECTOR_ICONS
+svg-contrast$(BUILD_EXEEXT): svg-contrast.c
+ $(CC_FOR_BUILD) -fPIC -o $@ $< $(NATIVE_GLIB_LIBS) $(CPPFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) $(NATIVE_GLIB_CFLAGS) $(libm)
+
+
+# compute_svg_viewbox is not built or used because librsvg is just too buggy
+# right now. But we keep the code around. The goal of this build tool will be
+# to be able to extract SVG icons from a single SVG file at build time, rather
+# than having to export and commit them manually.
+#compute_svg_viewbox_SOURCES = compute-svg-viewbox.c
+
+#compute_svg_viewbox_CFLAGS = $(SVG_CFLAGS)
+
+#compute_svg_viewbox_LDADD = $(SVG_LIBS)
+
+# Build tools which must be built for the host platform.
+all-local: svg-contrast$(BUILD_EXEEXT)
+
+DISTCLEANFILES = svg-contrast$(BUILD_EXEEXT)
+endif
+
+AM_CPPFLAGS = \
+ -DGIMP_APP_VERSION=\"@GIMP_APP_VERSION@\" \
+ -DLOCALEDIR=\""$(gimplocaledir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DEXEC_PREFIX=\""$(exec_prefix)"\" \
+ -DBINDIR=\""$(bindir)"\" \
+ -DSBINDIR=\""$(sbindir)"\" \
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DDATAROOTDIR=\""$(datarootdir)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DSHAREDSTATEDIR=\""$(sharedstatedir)"\" \
+ -DLOCALSTATEDIR=\""$(localstatedir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DINFODIR=\""$(infodir)"\" \
+ -DMANDIR=\""$(mandir)"\" \
+ -DGIMPPLUGINDIR=\""$(gimpplugindir)"\" \
+ -DGIMPDATADIR=\""$(gimpdatadir)"\" \
+ -DCC=\""$(CC)"\" \
+ -DGIMPDIR=\""$(gimpdir)"\" \
+ -DGIMP_PLUGIN_VERSION=\""$(GIMP_PLUGIN_VERSION)"\" \
+ -I$(top_srcdir) \
+ $(GTK_CFLAGS) \
+ -I$(includedir)
+
+AM_CFLAGS = \
+ $(xobjective_c)
+
+AM_CXXFLAGS = \
+ $(xobjective_cxx)
+
+AM_LDFLAGS = \
+ $(xnone)
+
+EXTRA_DIST = \
+ defcheck.py \
+ gimp-mkenums \
+ gimppath2svg.py \
+ svg-contrast.c \
+ mnemonic-clashes \
+ performance-log-close-tags.py \
+ performance-log-coalesce.py \
+ performance-log-deduce.py \
+ performance-log-expand.py \
+ performance-log-progressive-coalesce.py \
+ performance-log-resolve.py \
+ performance-log-viewer \
+ performance-log-viewer.py