summaryrefslogtreecommitdiffstats
path: root/devel-docs/libgimpmath/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'devel-docs/libgimpmath/Makefile.am')
-rw-r--r--devel-docs/libgimpmath/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/devel-docs/libgimpmath/Makefile.am b/devel-docs/libgimpmath/Makefile.am
new file mode 100644
index 0000000..b9352b4
--- /dev/null
+++ b/devel-docs/libgimpmath/Makefile.am
@@ -0,0 +1,49 @@
+## Process this file with automake to produce Makefile.in
+
+# The name of the module.
+DOC_MODULE = libgimpmath
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE = $(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code.
+DOC_SOURCE_DIR = $(top_srcdir)/$(DOC_MODULE)
+
+# Extra options to pass to gtkdoc-scangobj
+SCANGOBJ_OPTIONS =
+
+# Extra options to supply to gtkdoc-scan
+SCAN_OPTIONS =
+
+# Extra options to supply to gtkdoc-mkdb
+MKDB_OPTIONS = --sgml-mode --output-format=xml --name-space=gimp
+
+# Extra options to supply to gtkdoc-fixref
+FIXXREF_OPTIONS =
+
+# Used for dependencies
+HFILE_GLOB = $(DOC_SOURCE_DIR)/*.h
+CFILE_GLOB = $(DOC_SOURCE_DIR)/*.c
+
+# Header files to ignore when scanning
+IGNORE_HFILES =
+
+# Images to copy into HTML directory
+HTML_IMAGES=
+
+# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE)
+content_files =
+
+# Other files to distribute
+extra_files =
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+GTKDOC_CFLAGS =
+GTKDOC_LIBS =
+
+
+include $(top_srcdir)/gtk-doc.make
+
+# Other files to distribute
+EXTRA_DIST += version.in