summaryrefslogtreecommitdiffstats
path: root/debian/changelog.upstream.sh
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog.upstream.sh')
-rwxr-xr-xdebian/changelog.upstream.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/changelog.upstream.sh b/debian/changelog.upstream.sh
new file mode 100755
index 0000000..3441546
--- /dev/null
+++ b/debian/changelog.upstream.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+set -e
+: >debian/changelog.upstream
+exec <debian/versions.upstream
+read old
+while read new; do
+ exec >debian/changelog.upstream."$new"
+ echo "Version $new; changes since $old:"
+ echo "Version $new; changes since $old:" |tr '[:print:]' -
+ echo
+ git shortlog --no-merges "$old".."$new"
+ echo
+ cat debian/changelog.upstream
+ mv debian/changelog.upstream."$new" debian/changelog.upstream
+ old="$new"
+done