summaryrefslogtreecommitdiffstats
path: root/t/interop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 't/interop/Makefile')
-rw-r--r--t/interop/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/t/interop/Makefile b/t/interop/Makefile
new file mode 100644
index 0000000..6911c29
--- /dev/null
+++ b/t/interop/Makefile
@@ -0,0 +1,19 @@
+# Import tree-wide shared Makefile behavior and libraries
+include ../../shared.mak
+
+-include ../../config.mak
+export GIT_TEST_OPTIONS
+
+SHELL_PATH ?= $(SHELL)
+SHELL_PATH_SQ = $(subst ','\'',$(SHELL_PATH))
+T = $(sort $(wildcard i[0-9][0-9][0-9][0-9]-*.sh))
+
+all: $(T)
+
+$(T):
+ @echo "*** $@ ***"; '$(SHELL_PATH_SQ)' $@ $(GIT_TEST_OPTS)
+
+clean:
+ rm -rf build "trash directory".* test-results
+
+.PHONY: all clean $(T)