summaryrefslogtreecommitdiffstats
path: root/t/perf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 't/perf/Makefile')
-rw-r--r--t/perf/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/t/perf/Makefile b/t/perf/Makefile
new file mode 100644
index 0000000..e4808ae
--- /dev/null
+++ b/t/perf/Makefile
@@ -0,0 +1,21 @@
+# Import tree-wide shared Makefile behavior and libraries
+include ../../shared.mak
+
+-include ../../config.mak
+export GIT_TEST_OPTIONS
+
+all: test-lint perf
+
+perf: pre-clean
+ ./run
+
+pre-clean:
+ rm -rf test-results test-trace
+
+clean:
+ rm -rf build "trash directory".* test-results test-trace
+
+test-lint:
+ $(MAKE) -C .. test-lint
+
+.PHONY: all perf pre-clean clean