summaryrefslogtreecommitdiffstats
path: root/panels/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:45:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:45:20 +0000
commitae1c76ff830d146d41e88d6fba724c0a54bce868 (patch)
tree3c354bec95af07be35fc71a4b738268496f1a1c4 /panels/meson.build
parentInitial commit. (diff)
downloadgnome-control-center-ae1c76ff830d146d41e88d6fba724c0a54bce868.tar.xz
gnome-control-center-ae1c76ff830d146d41e88d6fba724c0a54bce868.zip
Adding upstream version 1:43.6.upstream/1%43.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'panels/meson.build')
-rw-r--r--panels/meson.build56
1 files changed, 56 insertions, 0 deletions
diff --git a/panels/meson.build b/panels/meson.build
new file mode 100644
index 0000000..cb732f2
--- /dev/null
+++ b/panels/meson.build
@@ -0,0 +1,56 @@
+subdir('common')
+
+panels = [
+ 'applications',
+ 'background',
+ 'camera',
+ 'color',
+ 'datetime',
+ 'default-apps',
+ 'diagnostics',
+ 'display',
+ 'firmware-security',
+ 'info-overview',
+ 'keyboard',
+ 'location',
+ 'microphone',
+ 'mouse',
+ 'multitasking',
+ 'notifications',
+ 'online-accounts',
+ 'power',
+ 'printers',
+ 'region',
+ 'removable-media',
+ 'screen',
+ 'search',
+ 'sharing',
+ 'sound',
+ 'universal-access',
+ 'usage',
+ 'user-accounts',
+ 'wwan',
+]
+
+if host_is_linux
+ panels += ['network']
+endif
+
+if host_is_linux_not_s390
+ panels += [
+ 'bluetooth',
+ 'thunderbolt',
+ 'wacom'
+ ]
+endif
+
+panels_list = []
+panels_libs = []
+foreach cappletname: panels
+ cflags = [
+ '-DG_LOG_DOMAIN="@0@-cc-panel"'.format(cappletname),
+ '-DPANEL_ID="@0@"'.format(cappletname)
+ ]
+
+ subdir(cappletname)
+endforeach