summaryrefslogtreecommitdiffstats
path: root/panels/microphone
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:45:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:45:20 +0000
commitae1c76ff830d146d41e88d6fba724c0a54bce868 (patch)
tree3c354bec95af07be35fc71a4b738268496f1a1c4 /panels/microphone
parentInitial commit. (diff)
downloadgnome-control-center-ae1c76ff830d146d41e88d6fba724c0a54bce868.tar.xz
gnome-control-center-ae1c76ff830d146d41e88d6fba724c0a54bce868.zip
Adding upstream version 1:43.6.upstream/1%43.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'panels/microphone')
-rw-r--r--panels/microphone/cc-microphone-panel.c413
-rw-r--r--panels/microphone/cc-microphone-panel.h30
-rw-r--r--panels/microphone/cc-microphone-panel.ui74
-rw-r--r--panels/microphone/gnome-microphone-panel.desktop.in.in19
-rw-r--r--panels/microphone/icons/meson.build4
-rw-r--r--panels/microphone/icons/scalable/org.gnome.Settings-microphone-symbolic.svg4
-rw-r--r--panels/microphone/meson.build41
-rw-r--r--panels/microphone/microphone.gresource.xml6
8 files changed, 591 insertions, 0 deletions
diff --git a/panels/microphone/cc-microphone-panel.c b/panels/microphone/cc-microphone-panel.c
new file mode 100644
index 0000000..5b56c24
--- /dev/null
+++ b/panels/microphone/cc-microphone-panel.c
@@ -0,0 +1,413 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*-
+ *
+ * Copyright (C) 2018 Red Hat, Inc
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, see <http://www.gnu.org/licenses/>.
+ *
+ * Author: Matthias Clasen <mclasen@redhat.com>
+ */
+
+#include "cc-microphone-panel.h"
+#include "cc-microphone-resources.h"
+#include "cc-util.h"
+
+#include <gio/gdesktopappinfo.h>
+#include <glib/gi18n.h>
+
+#define APP_PERMISSIONS_TABLE "devices"
+#define APP_PERMISSIONS_ID "microphone"
+
+struct _CcMicrophonePanel
+{
+ CcPanel parent_instance;
+
+ GtkSwitch *main_switch;
+ GtkListBox *microphone_apps_list_box;
+ GtkStack *stack;
+
+ GSettings *privacy_settings;
+
+ GDBusProxy *perm_store;
+ GVariant *microphone_apps_perms;
+ GVariant *microphone_apps_data;
+ GHashTable *microphone_app_switches;
+
+ GtkSizeGroup *microphone_icon_size_group;
+};
+
+CC_PANEL_REGISTER (CcMicrophonePanel, cc_microphone_panel)
+
+typedef struct
+{
+ CcMicrophonePanel *self;
+ GtkWidget *widget;
+ gchar *app_id;
+ gboolean changing_state;
+ gboolean pending_state;
+} MicrophoneAppStateData;
+
+static void
+microphone_app_state_data_free (MicrophoneAppStateData *data)
+{
+ g_free (data->app_id);
+ g_slice_free (MicrophoneAppStateData, data);
+}
+
+static void
+on_perm_store_set_done (GObject *source_object,
+ GAsyncResult *res,
+ gpointer user_data)
+{
+ MicrophoneAppStateData *data;
+ GVariant *results;
+ GError *error = NULL;
+
+ results = g_dbus_proxy_call_finish (G_DBUS_PROXY (source_object),
+ res,
+ &error);
+ if (results == NULL)
+ {
+ if (!g_error_matches (error, G_IO_ERROR, G_IO_ERROR_CANCELLED))
+ g_warning ("Failed to store permissions: %s", error->message);
+ g_error_free (error);
+
+ return;
+ }
+ g_variant_unref (results);
+
+ data = (MicrophoneAppStateData *) user_data;
+ data->changing_state = FALSE;
+ gtk_switch_set_state (GTK_SWITCH (data->widget), data->pending_state);
+}
+
+static gboolean
+on_microphone_app_state_set (GtkSwitch *widget,
+ gboolean state,
+ gpointer user_data)
+{
+ MicrophoneAppStateData *data = (MicrophoneAppStateData *) user_data;
+ CcMicrophonePanel *self = data->self;
+ GVariant *params;
+ GVariantIter iter;
+ const gchar *key;
+ gchar **value;
+ GVariantBuilder builder;
+
+ if (data->changing_state)
+ return TRUE;
+
+ data->changing_state = TRUE;
+ data->pending_state = state;
+
+ g_variant_iter_init (&iter, self->microphone_apps_perms);
+ g_variant_builder_init (&builder, G_VARIANT_TYPE_ARRAY);
+ while (g_variant_iter_loop (&iter, "{&s^a&s}", &key, &value))
+ {
+ if (g_strv_length (value) != 1)
+ /* It's OK to drop the entry if it's not in expected format */
+ continue;
+
+ if (g_strcmp0 (data->app_id, key) == 0)
+ value[0] = state ? "yes" : "no";
+
+ g_variant_builder_add (&builder, "{s^as}", key, value);
+ }
+
+ params = g_variant_new ("(sbsa{sas}v)",
+ APP_PERMISSIONS_TABLE,
+ TRUE,
+ APP_PERMISSIONS_ID,
+ &builder,
+ self->microphone_apps_data);
+
+ g_dbus_proxy_call (self->perm_store,
+ "Set",
+ params,
+ G_DBUS_CALL_FLAGS_NONE,
+ -1,
+ cc_panel_get_cancellable (CC_PANEL (self)),
+ on_perm_store_set_done,
+ data);
+
+ return TRUE;
+}
+
+static void
+add_microphone_app (CcMicrophonePanel *self,
+ const gchar *app_id,
+ gboolean enabled)
+{
+ GDesktopAppInfo *app_info;
+ char *desktop_id;
+ GtkWidget *row, *w;
+ GIcon *icon;
+ MicrophoneAppStateData *data;
+
+ w = g_hash_table_lookup (self->microphone_app_switches, app_id);
+ if (w != NULL)
+ {
+ gtk_switch_set_active (GTK_SWITCH (w), enabled);
+
+ return;
+ }
+
+ desktop_id = g_strdup_printf ("%s.desktop", app_id);
+ app_info = g_desktop_app_info_new (desktop_id);
+ g_free (desktop_id);
+ if (app_info == NULL)
+ return;
+
+ row = adw_action_row_new ();
+ gtk_list_box_append (self->microphone_apps_list_box, row);
+
+ icon = g_app_info_get_icon (G_APP_INFO (app_info));
+ w = gtk_image_new_from_gicon (icon);
+ gtk_widget_set_valign (w, GTK_ALIGN_CENTER);
+ gtk_size_group_add_widget (self->microphone_icon_size_group, w);
+ adw_action_row_add_prefix (ADW_ACTION_ROW (row), w);
+
+ adw_preferences_row_set_title (ADW_PREFERENCES_ROW (row),
+ g_app_info_get_name (G_APP_INFO (app_info)));
+
+ w = gtk_switch_new ();
+ gtk_switch_set_active (GTK_SWITCH (w), enabled);
+ gtk_widget_set_valign (w, GTK_ALIGN_CENTER);
+ adw_action_row_add_suffix (ADW_ACTION_ROW (row), w);
+ g_settings_bind (self->privacy_settings,
+ "disable-microphone",
+ w,
+ "sensitive",
+ G_SETTINGS_BIND_INVERT_BOOLEAN);
+ g_hash_table_insert (self->microphone_app_switches,
+ g_strdup (app_id),
+ g_object_ref (w));
+
+ data = g_slice_new (MicrophoneAppStateData);
+ data->self = self;
+ data->app_id = g_strdup (app_id);
+ data->widget = w;
+ data->changing_state = FALSE;
+ g_signal_connect_data (G_OBJECT (w),
+ "state-set",
+ G_CALLBACK (on_microphone_app_state_set),
+ data,
+ (GClosureNotify) microphone_app_state_data_free,
+ 0);
+}
+
+static gboolean
+to_child_name (GBinding *binding,
+ const GValue *from,
+ GValue *to,
+ gpointer user_data)
+{
+ if (g_value_get_boolean (from))
+ g_value_set_string (to, "content");
+ else
+ g_value_set_string (to, "empty");
+ return TRUE;
+}
+
+/* Steals permissions and permissions_data references */
+static void
+update_perm_store (CcMicrophonePanel *self,
+ GVariant *permissions,
+ GVariant *permissions_data)
+{
+ GVariantIter iter;
+ const gchar *key;
+ gchar **value;
+
+ g_clear_pointer (&self->microphone_apps_perms, g_variant_unref);
+ self->microphone_apps_perms = permissions;
+ g_clear_pointer (&self->microphone_apps_data, g_variant_unref);
+ self->microphone_apps_data = permissions_data;
+
+ g_variant_iter_init (&iter, permissions);
+ while (g_variant_iter_loop (&iter, "{&s^a&s}", &key, &value))
+ {
+ gboolean enabled;
+
+ if (g_strv_length (value) != 1)
+ {
+ g_debug ("Permissions for %s in incorrect format, ignoring.", key);
+ continue;
+ }
+
+ enabled = (g_strcmp0 (value[0], "no") != 0);
+
+ add_microphone_app (self, key, enabled);
+ }
+}
+
+static void
+on_perm_store_signal (GDBusProxy *proxy,
+ gchar *sender_name,
+ gchar *signal_name,
+ GVariant *parameters,
+ gpointer user_data)
+{
+ GVariant *permissions, *permissions_data;
+
+ if (g_strcmp0 (signal_name, "Changed") != 0)
+ return;
+
+ permissions = g_variant_get_child_value (parameters, 4);
+ permissions_data = g_variant_get_child_value (parameters, 3);
+ update_perm_store (user_data, permissions, permissions_data);
+}
+
+static void
+on_perm_store_lookup_done (GObject *source_object,
+ GAsyncResult *res,
+ gpointer user_data)
+{
+ CcMicrophonePanel *self = user_data;
+ g_autoptr(GError) error = NULL;
+ GVariant *ret, *permissions, *permissions_data;
+
+ ret = g_dbus_proxy_call_finish (G_DBUS_PROXY (source_object),
+ res,
+ &error);
+ if (ret == NULL)
+ {
+ if (!g_error_matches (error, G_IO_ERROR, G_IO_ERROR_CANCELLED))
+ g_warning ("Failed fetch permissions from flatpak permission store: %s", error->message);
+ return;
+ }
+
+ permissions = g_variant_get_child_value (ret, 0);
+ permissions_data = g_variant_get_child_value (ret, 1);
+ update_perm_store (user_data, permissions, permissions_data);
+
+ g_signal_connect_object (source_object,
+ "g-signal",
+ G_CALLBACK (on_perm_store_signal),
+ self,
+ 0);
+}
+
+static void
+on_perm_store_ready (GObject *source_object,
+ GAsyncResult *res,
+ gpointer user_data)
+{
+ CcMicrophonePanel *self;
+ g_autoptr(GError) error = NULL;
+ GDBusProxy *proxy;
+ GVariant *params;
+
+ proxy = g_dbus_proxy_new_for_bus_finish (res, &error);
+ if (proxy == NULL)
+ {
+ if (!g_error_matches (error, G_IO_ERROR, G_IO_ERROR_CANCELLED))
+ g_warning ("Failed to connect to flatpak permission store: %s", error->message);
+ return;
+ }
+ self = user_data;
+ self->perm_store = proxy;
+
+ params = g_variant_new ("(ss)",
+ APP_PERMISSIONS_TABLE,
+ APP_PERMISSIONS_ID);
+ g_dbus_proxy_call (self->perm_store,
+ "Lookup",
+ params,
+ G_DBUS_CALL_FLAGS_NONE,
+ -1,
+ cc_panel_get_cancellable (CC_PANEL (self)),
+ on_perm_store_lookup_done,
+ self);
+}
+
+static void
+cc_microphone_panel_finalize (GObject *object)
+{
+ CcMicrophonePanel *self = CC_MICROPHONE_PANEL (object);
+
+ g_clear_object (&self->privacy_settings);
+ g_clear_object (&self->perm_store);
+ g_clear_object (&self->microphone_icon_size_group);
+ g_clear_pointer (&self->microphone_apps_perms, g_variant_unref);
+ g_clear_pointer (&self->microphone_apps_data, g_variant_unref);
+ g_clear_pointer (&self->microphone_app_switches, g_hash_table_unref);
+
+ G_OBJECT_CLASS (cc_microphone_panel_parent_class)->finalize (object);
+}
+
+static const char *
+cc_microphone_panel_get_help_uri (CcPanel *panel)
+{
+ return "help:gnome-help/microphone";
+}
+
+static void
+cc_microphone_panel_class_init (CcMicrophonePanelClass *klass)
+{
+ CcPanelClass *panel_class = CC_PANEL_CLASS (klass);
+ GtkWidgetClass *widget_class = GTK_WIDGET_CLASS (klass);
+ GObjectClass *object_class = G_OBJECT_CLASS (klass);
+
+ panel_class->get_help_uri = cc_microphone_panel_get_help_uri;
+
+ object_class->finalize = cc_microphone_panel_finalize;
+
+ gtk_widget_class_set_template_from_resource (widget_class, "/org/gnome/control-center/microphone/cc-microphone-panel.ui");
+
+ gtk_widget_class_bind_template_child (widget_class, CcMicrophonePanel, main_switch);
+ gtk_widget_class_bind_template_child (widget_class, CcMicrophonePanel, stack);
+ gtk_widget_class_bind_template_child (widget_class, CcMicrophonePanel, microphone_apps_list_box);
+}
+
+static void
+cc_microphone_panel_init (CcMicrophonePanel *self)
+{
+ g_resources_register (cc_microphone_get_resource ());
+
+ gtk_widget_init_template (GTK_WIDGET (self));
+
+ self->microphone_icon_size_group = gtk_size_group_new (GTK_SIZE_GROUP_BOTH);
+
+ self->privacy_settings = g_settings_new ("org.gnome.desktop.privacy");
+
+ g_settings_bind (self->privacy_settings,
+ "disable-microphone",
+ self->main_switch,
+ "active",
+ G_SETTINGS_BIND_INVERT_BOOLEAN);
+
+ g_object_bind_property_full (self->main_switch,
+ "active",
+ self->stack,
+ "visible-child-name",
+ G_BINDING_SYNC_CREATE,
+ to_child_name,
+ NULL,
+ NULL, NULL);
+
+ self->microphone_app_switches = g_hash_table_new_full (g_str_hash,
+ g_str_equal,
+ g_free,
+ g_object_unref);
+
+ g_dbus_proxy_new_for_bus (G_BUS_TYPE_SESSION,
+ G_DBUS_PROXY_FLAGS_NONE,
+ NULL,
+ "org.freedesktop.impl.portal.PermissionStore",
+ "/org/freedesktop/impl/portal/PermissionStore",
+ "org.freedesktop.impl.portal.PermissionStore",
+ cc_panel_get_cancellable (CC_PANEL (self)),
+ on_perm_store_ready,
+ self);
+}
diff --git a/panels/microphone/cc-microphone-panel.h b/panels/microphone/cc-microphone-panel.h
new file mode 100644
index 0000000..7b5aee5
--- /dev/null
+++ b/panels/microphone/cc-microphone-panel.h
@@ -0,0 +1,30 @@
+/* -*- mode: C; c-file-style: "gnu"; indent-tabs-mode: nil; -*-
+ *
+ * Copyright (C) 2018 Red Hat, Inc
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, see <http://www.gnu.org/licenses/>.
+ *
+ * Author: Matthias Clasen <mclasen@redhat.com>
+ */
+
+#pragma once
+
+#include <shell/cc-panel.h>
+
+G_BEGIN_DECLS
+
+#define CC_TYPE_MICROPHONE_PANEL (cc_microphone_panel_get_type ())
+G_DECLARE_FINAL_TYPE (CcMicrophonePanel, cc_microphone_panel, CC, MICROPHONE_PANEL, CcPanel)
+
+G_END_DECLS
diff --git a/panels/microphone/cc-microphone-panel.ui b/panels/microphone/cc-microphone-panel.ui
new file mode 100644
index 0000000..96695f1
--- /dev/null
+++ b/panels/microphone/cc-microphone-panel.ui
@@ -0,0 +1,74 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<interface>
+ <template class="CcMicrophonePanel" parent="CcPanel">
+
+ <child type="titlebar-end">
+ <object class="GtkSwitch" id="main_switch">
+ <property name="valign">center</property>
+ <accessibility>
+ <property name="label" translatable="yes">Enable</property>
+ </accessibility>
+ </object>
+ </child>
+
+ <child type="content">
+ <object class="GtkStack" id="stack">
+
+ <child>
+ <object class="GtkStackPage">
+ <property name="name">empty</property>
+ <property name="child">
+ <object class="AdwStatusPage">
+ <property name="icon-name">microphone-disabled-symbolic</property>
+ <property name="title" translatable="yes">Microphone Turned Off</property>
+ <property name="description" translatable="yes">No applications can record sound.</property>
+ </object>
+ </property>
+ </object>
+ </child>
+
+ <child>
+ <object class="GtkStackPage">
+ <property name="name">content</property>
+ <property name="child">
+ <object class="AdwPreferencesPage">
+ <child>
+ <object class="AdwPreferencesGroup">
+ <property name="description" translatable="yes">Use of the microphone allows applications to record and listen to audio. Disabling the microphone may cause some applications to not function properly.
+
+Allow the applications below to use your microphone.</property>
+ <child>
+ <object class="GtkListBox" id="microphone_apps_list_box">
+ <property name="can-focus">true</property>
+ <property name="selection-mode">none</property>
+ <style>
+ <class name="boxed-list"/>
+ </style>
+
+ <child type="placeholder">
+ <object class="GtkLabel">
+ <property name="margin-top">18</property>
+ <property name="margin-bottom">18</property>
+ <property name="margin-start">18</property>
+ <property name="margin-end">18</property>
+ <property name="label" translatable="yes">No Applications Have Asked for Microphone Access</property>
+ <property name="wrap">true</property>
+ <property name="max-width-chars">50</property>
+ <style>
+ <class name="dim-label" />
+ </style>
+ </object>
+ </child>
+ </object>
+ </child>
+ </object>
+ </child>
+ </object>
+ </property>
+ </object>
+ </child>
+
+ </object>
+ </child>
+ </template>
+</interface>
diff --git a/panels/microphone/gnome-microphone-panel.desktop.in.in b/panels/microphone/gnome-microphone-panel.desktop.in.in
new file mode 100644
index 0000000..1db40c4
--- /dev/null
+++ b/panels/microphone/gnome-microphone-panel.desktop.in.in
@@ -0,0 +1,19 @@
+[Desktop Entry]
+Name=Microphone
+Comment=Protect your conversations
+Exec=gnome-control-center microphone
+# FIXME
+# Translators: Do NOT translate or transliterate this text (this is an icon file name)!
+Icon=org.gnome.Settings-microphone-symbolic
+Terminal=false
+Type=Application
+NoDisplay=true
+StartupNotify=true
+Categories=GNOME;GTK;Settings;DesktopSettings;X-GNOME-Settings-Panel;X-GNOME-PrivacySettings;
+OnlyShowIn=GNOME;Unity;
+X-GNOME-Bugzilla-Bugzilla=GNOME
+X-GNOME-Bugzilla-Product=gnome-control-center
+X-GNOME-Bugzilla-Component=privacy
+X-GNOME-Bugzilla-Version=@VERSION@
+# Translators: Search terms to find the Microphone panel. Do NOT translate or localize the semicolons! The list MUST also end with a semicolon!
+Keywords=microphone;recording;application;privacy;
diff --git a/panels/microphone/icons/meson.build b/panels/microphone/icons/meson.build
new file mode 100644
index 0000000..d7c487d
--- /dev/null
+++ b/panels/microphone/icons/meson.build
@@ -0,0 +1,4 @@
+install_data(
+ 'scalable/org.gnome.Settings-microphone-symbolic.svg',
+ install_dir: join_paths(control_center_icondir, 'hicolor', 'scalable', 'apps')
+)
diff --git a/panels/microphone/icons/scalable/org.gnome.Settings-microphone-symbolic.svg b/panels/microphone/icons/scalable/org.gnome.Settings-microphone-symbolic.svg
new file mode 100644
index 0000000..55c9407
--- /dev/null
+++ b/panels/microphone/icons/scalable/org.gnome.Settings-microphone-symbolic.svg
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<svg height="16px" viewBox="0 0 16 16" width="16px" xmlns="http://www.w3.org/2000/svg">
+ <path d="m 8 0 c -1.660156 0 -3 1.339844 -3 3 v 5 c 0 1.660156 1.339844 3 3 3 s 3 -1.339844 3 -3 v -5 c 0 -1.660156 -1.339844 -3 -3 -3 z m -6 6 v 2.011719 c 0 2.964843 2.164062 5.421875 5 5.898437 v 2.089844 h 2 v -2.089844 c 2.835938 -0.476562 5 -2.933594 5 -5.898437 v -2.011719 h -1.5 v 2.011719 c 0 2.5 -1.992188 4.488281 -4.5 4.488281 s -4.5 -1.988281 -4.5 -4.488281 v -2.011719 z m 0 0" fill="#2e3436"/>
+</svg>
diff --git a/panels/microphone/meson.build b/panels/microphone/meson.build
new file mode 100644
index 0000000..16647a5
--- /dev/null
+++ b/panels/microphone/meson.build
@@ -0,0 +1,41 @@
+panels_list += cappletname
+desktop = 'gnome-@0@-panel.desktop'.format(cappletname)
+
+desktop_in = configure_file(
+ input: desktop + '.in.in',
+ output: desktop + '.in',
+ configuration: desktop_conf
+)
+
+i18n.merge_file(
+ type: 'desktop',
+ input: desktop_in,
+ output: desktop,
+ po_dir: po_dir,
+ install: true,
+ install_dir: control_center_desktopdir
+)
+
+sources = files('cc-microphone-panel.c')
+
+resource_data = files('cc-microphone-panel.ui')
+
+sources += gnome.compile_resources(
+ 'cc-' + cappletname + '-resources',
+ cappletname + '.gresource.xml',
+ c_name: 'cc_' + cappletname,
+ dependencies: resource_data,
+ export: true
+)
+
+cflags += '-DGNOMELOCALEDIR="@0@"'.format(control_center_localedir)
+
+panels_libs += static_library(
+ cappletname,
+ sources: sources,
+ include_directories: [top_inc, common_inc],
+ dependencies: common_deps,
+ c_args: cflags
+)
+
+subdir('icons')
diff --git a/panels/microphone/microphone.gresource.xml b/panels/microphone/microphone.gresource.xml
new file mode 100644
index 0000000..f3f938e
--- /dev/null
+++ b/panels/microphone/microphone.gresource.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<gresources>
+ <gresource prefix="/org/gnome/control-center/microphone">
+ <file preprocess="xml-stripblanks">cc-microphone-panel.ui</file>
+ </gresource>
+</gresources>