summaryrefslogtreecommitdiffstats
path: root/search-provider/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:45:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:45:20 +0000
commitae1c76ff830d146d41e88d6fba724c0a54bce868 (patch)
tree3c354bec95af07be35fc71a4b738268496f1a1c4 /search-provider/meson.build
parentInitial commit. (diff)
downloadgnome-control-center-upstream.tar.xz
gnome-control-center-upstream.zip
Adding upstream version 1:43.6.upstream/1%43.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'search-provider/meson.build')
-rw-r--r--search-provider/meson.build47
1 files changed, 47 insertions, 0 deletions
diff --git a/search-provider/meson.build b/search-provider/meson.build
new file mode 100644
index 0000000..624641a
--- /dev/null
+++ b/search-provider/meson.build
@@ -0,0 +1,47 @@
+service_conf = configuration_data()
+service_conf.set('libexecdir', control_center_libexecdir)
+
+service = 'org.gnome.Settings.SearchProvider.service'
+
+configure_file(
+ input : service + '.in',
+ output : service,
+ install : true,
+ install_dir : join_paths(control_center_datadir, 'dbus-1', 'services'),
+ configuration : service_conf
+)
+
+install_data(
+ 'org.gnome.Settings.search-provider.ini',
+ install_dir: join_paths(control_center_datadir, 'gnome-shell', 'search-providers')
+)
+
+sources = files(
+ 'cc-search-provider.c',
+ 'control-center-search-provider.c'
+)
+
+# The upstream for the DBus interface definition is
+# at http://git.gnome.org/browse/gnome-shell/plain/data/org.gnome.ShellSearchProvider2.xml
+sources += gnome.gdbus_codegen(
+ 'cc-shell-search-provider-generated',
+ 'org.gnome.ShellSearchProvider2.xml',
+ interface_prefix : 'org.gnome.',
+ namespace : 'Cc'
+)
+
+libs = [
+ libpanel_loader,
+ libshell
+]
+
+executable(
+ 'gnome-control-center-search-provider',
+ sources,
+ include_directories : top_inc,
+ dependencies : shell_deps,
+ c_args : cflags,
+ link_with : libs,
+ install : true,
+ install_dir : control_center_libexecdir
+)