summaryrefslogtreecommitdiffstats
path: root/tests/datetime/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:45:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:45:20 +0000
commitae1c76ff830d146d41e88d6fba724c0a54bce868 (patch)
tree3c354bec95af07be35fc71a4b738268496f1a1c4 /tests/datetime/meson.build
parentInitial commit. (diff)
downloadgnome-control-center-upstream.tar.xz
gnome-control-center-upstream.zip
Adding upstream version 1:43.6.upstream/1%43.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/datetime/meson.build')
-rw-r--r--tests/datetime/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/datetime/meson.build b/tests/datetime/meson.build
new file mode 100644
index 0000000..c9f0787
--- /dev/null
+++ b/tests/datetime/meson.build
@@ -0,0 +1,34 @@
+
+test_units = [
+ 'test-timezone',
+ 'test-timezone-gfx',
+ 'test-endianess',
+]
+
+env = [
+ 'G_MESSAGES_DEBUG=all',
+ 'BUILDDIR=' + meson.current_build_dir(),
+ 'TOP_BUILDDIR=' + meson.build_root(),
+# Disable ATK, this should not be required but it caused CI failures -- 2018-12-07
+ 'NO_AT_BRIDGE=1'
+]
+cflags = [
+ '-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir()),
+ '-DSRCDIR="@0@"'.format(meson.source_root() + '/panels/datetime')
+]
+
+foreach unit: test_units
+ exe = executable(
+ unit,
+ [unit + '.c'],
+ dependencies : common_deps + [m_dep, datetime_panel_lib_dep],
+ c_args : cflags
+ )
+endforeach
+
+test(
+ 'test-datetime',
+ find_program('test-datetime.py'),
+ env : env,
+ timeout : 60
+)