summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/build-Look-for-snapd-glib-2.patch21
-rw-r--r--debian/patches/debian/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch37
-rw-r--r--debian/patches/debian/Expose-touchpad-settings-if-synaptics-is-in-use.patch88
-rw-r--r--debian/patches/debian/Ignore-result-of-test-network-panel.patch39
-rw-r--r--debian/patches/debian/firmware-security-disable.patch31
-rw-r--r--debian/patches/keyboard-Allow-disabling-alternate-characters-key.patch32
-rw-r--r--debian/patches/series6
7 files changed, 254 insertions, 0 deletions
diff --git a/debian/patches/build-Look-for-snapd-glib-2.patch b/debian/patches/build-Look-for-snapd-glib-2.patch
new file mode 100644
index 0000000..e3b4793
--- /dev/null
+++ b/debian/patches/build-Look-for-snapd-glib-2.patch
@@ -0,0 +1,21 @@
+From: Jeremy Bicha <jeremy.bicha@canonical.com>
+Date: Fri, 26 Aug 2022 08:53:00 -0400
+Subject: build: Look for snapd-glib-2
+
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index fb9b9cd..16d24ed 100644
+--- a/meson.build
++++ b/meson.build
+@@ -204,7 +204,7 @@ config_h.set10('HAVE_FN_EXPLICIT_BZERO',
+ enable_snap = get_option('snap')
+ if enable_snap
+ snapd_glib_deps = [
+- dependency('snapd-glib', version: '>= 1.57')
++ dependency('snapd-glib-2', version: '>= 1.57')
+ ]
+ endif
+ config_h.set('HAVE_SNAP', enable_snap,
diff --git a/debian/patches/debian/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch b/debian/patches/debian/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch
new file mode 100644
index 0000000..cf91000
--- /dev/null
+++ b/debian/patches/debian/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch
@@ -0,0 +1,37 @@
+From: Andrea Azzarone <andrea.azzarone@canonical.com>
+Date: Tue, 31 Jul 2018 04:44:11 +0100
+Subject: Debian's adduser doesn't allow uppercase letters by default.
+
+Forwarded: not-needed, Debian-specific
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910141
+---
+ panels/user-accounts/cc-add-user-dialog.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/panels/user-accounts/cc-add-user-dialog.c b/panels/user-accounts/cc-add-user-dialog.c
+index e462015..031eaa7 100644
+--- a/panels/user-accounts/cc-add-user-dialog.c
++++ b/panels/user-accounts/cc-add-user-dialog.c
+@@ -229,6 +229,7 @@ create_user_done (ActUserManager *manager,
+ static void
+ local_create_user (CcAddUserDialog *self)
+ {
++ g_autofree char *debian_username = NULL;
+ ActUserManager *manager;
+ const gchar *username;
+ const gchar *name;
+@@ -240,11 +241,12 @@ local_create_user (CcAddUserDialog *self)
+ username = gtk_combo_box_text_get_active_text (self->local_username_combo);
+ account_type = gtk_switch_get_active (self->local_account_type_switch) ? ACT_USER_ACCOUNT_TYPE_ADMINISTRATOR : ACT_USER_ACCOUNT_TYPE_STANDARD;
+
+- g_debug ("Creating local user: %s", username);
++ debian_username = g_ascii_strdown (username, -1);
++ g_debug ("Creating local user: %s", debian_username);
+
+ manager = act_user_manager_get_default ();
+ act_user_manager_create_user_async (manager,
+- username,
++ debian_username,
+ name,
+ account_type,
+ self->cancellable,
diff --git a/debian/patches/debian/Expose-touchpad-settings-if-synaptics-is-in-use.patch b/debian/patches/debian/Expose-touchpad-settings-if-synaptics-is-in-use.patch
new file mode 100644
index 0000000..3c8f9ab
--- /dev/null
+++ b/debian/patches/debian/Expose-touchpad-settings-if-synaptics-is-in-use.patch
@@ -0,0 +1,88 @@
+From: Daniel van Vugt <daniel.van.vugt@canonical.com>
+Date: Fri, 16 Mar 2018 13:53:10 -0400
+Subject: Expose touchpad settings if synaptics is in use
+
+Upstream is aggressively pushing for libinput over synaptics. However that
+creates a factually incorrect situation where gnome-control-center thinks
+there is no touchpad unless you're using the xserver-xorg-input-libinput.
+This patch adds support for both drivers, removing the code that would
+hide the touchpad settings when xserver-xorg-input-synaptics is in use.
+
+This patch is only useful in the GNOME on Xorg session.
+In GNOME on Wayland, libinput is used anyway.
+
+This patch requires a companion patch in mutter which GNOME has rejected.
+
+https://gitlab.gnome.org/GNOME/mutter/merge_requests/37
+---
+ panels/mouse/cc-mouse-caps-helper.c | 7 +++++++
+ panels/mouse/cc-mouse-panel.c | 16 +++++++++-------
+ 2 files changed, 16 insertions(+), 7 deletions(-)
+
+diff --git a/panels/mouse/cc-mouse-caps-helper.c b/panels/mouse/cc-mouse-caps-helper.c
+index 6658f41..12aafdb 100644
+--- a/panels/mouse/cc-mouse-caps-helper.c
++++ b/panels/mouse/cc-mouse-caps-helper.c
+@@ -38,6 +38,13 @@ touchpad_check_capabilities_x11 (gboolean *have_two_finger_scrolling,
+ unsigned long nitems, bytes_after;
+ unsigned char *data;
+
++ if (cc_synaptics_check ()) {
++ *have_two_finger_scrolling = TRUE;
++ *have_edge_scrolling = TRUE;
++ *have_tap_to_click = TRUE;
++ return TRUE;
++ }
++
+ gdisplay = gdk_display_get_default ();
+ display = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
+ prop_scroll_methods = XInternAtom (display, "libinput Scroll Methods Available", False);
+diff --git a/panels/mouse/cc-mouse-panel.c b/panels/mouse/cc-mouse-panel.c
+index cdd28ab..6d1269a 100644
+--- a/panels/mouse/cc-mouse-panel.c
++++ b/panels/mouse/cc-mouse-panel.c
+@@ -64,7 +64,6 @@ struct _CcMousePanel
+ gboolean have_mouse;
+ gboolean have_touchpad;
+ gboolean have_touchscreen;
+- gboolean have_synaptics;
+
+ gboolean left_handed;
+ GtkGesture *left_gesture;
+@@ -82,7 +81,7 @@ setup_touchpad_options (CcMousePanel *self)
+ gboolean have_edge_scrolling;
+ gboolean have_tap_to_click;
+
+- if (self->have_synaptics || !self->have_touchpad) {
++ if (!self->have_touchpad) {
+ gtk_widget_hide (GTK_WIDGET (self->touchpad_group));
+ return;
+ }
+@@ -308,7 +307,10 @@ setup_dialog (CcMousePanel *self)
+ static void
+ device_changed (CcMousePanel *self)
+ {
+- self->have_touchpad = touchpad_is_present ();
++ self->have_touchpad = touchpad_is_present () || cc_synaptics_check ();
++ /* ^^^^^^^^^^^^^^^^^^^^^
++ * Workaround https://gitlab.gnome.org/GNOME/gtk/issues/97
++ */
+
+ setup_touchpad_options (self);
+
+@@ -363,11 +365,11 @@ cc_mouse_panel_init (CcMousePanel *self)
+ G_CALLBACK (device_changed), self, G_CONNECT_SWAPPED);
+
+ self->have_mouse = mouse_is_present ();
+- self->have_touchpad = touchpad_is_present ();
++ self->have_touchpad = touchpad_is_present () || cc_synaptics_check ();
++ /* ^^^^^^^^^^^^^^^^^^^^^
++ * Workaround https://gitlab.gnome.org/GNOME/gtk/issues/97
++ */
+ self->have_touchscreen = touchscreen_is_present ();
+- self->have_synaptics = cc_synaptics_check ();
+- if (self->have_synaptics)
+- g_warning ("Detected synaptics X driver, please migrate to libinput");
+
+ setup_dialog (self);
+ }
diff --git a/debian/patches/debian/Ignore-result-of-test-network-panel.patch b/debian/patches/debian/Ignore-result-of-test-network-panel.patch
new file mode 100644
index 0000000..10b0013
--- /dev/null
+++ b/debian/patches/debian/Ignore-result-of-test-network-panel.patch
@@ -0,0 +1,39 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Fri, 15 Apr 2022 11:38:23 +0100
+Subject: Ignore result of test-network-panel
+
+This is a workaround for the test intermittently failing, especially
+on slower architectures. Continue to run it with the result ignored,
+and force its output to be logged, so that we can see how often it
+fails in practice.
+
+Bug: https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1768
+Forwarded: not-needed, Debian-specific workaround
+---
+ tests/network/meson.build | 1 +
+ tests/network/test-network-panel.py | 3 ++-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tests/network/meson.build b/tests/network/meson.build
+index 34f7c74..203af9d 100644
+--- a/tests/network/meson.build
++++ b/tests/network/meson.build
+@@ -29,6 +29,7 @@ test(
+ 'test-network-panel',
+ find_program('test-network-panel.py'),
+ env : envs,
++ verbose : true,
+ timeout : 60
+ )
+
+diff --git a/tests/network/test-network-panel.py b/tests/network/test-network-panel.py
+index 1098bab..dac0894 100644
+--- a/tests/network/test-network-panel.py
++++ b/tests/network/test-network-panel.py
+@@ -41,4 +41,5 @@ class PanelTestCase(X11SessionTestCase, GTest):
+
+ if __name__ == '__main__':
+ # avoid writing to stderr
+- unittest.main(testRunner=unittest.TextTestRunner(stream=sys.stdout, verbosity=2))
++ # TODO: result is ignored: https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1768
++ unittest.main(testRunner=unittest.TextTestRunner(stream=sys.stdout, verbosity=2), exit=False)
diff --git a/debian/patches/debian/firmware-security-disable.patch b/debian/patches/debian/firmware-security-disable.patch
new file mode 100644
index 0000000..54281a8
--- /dev/null
+++ b/debian/patches/debian/firmware-security-disable.patch
@@ -0,0 +1,31 @@
+From: Jeremy Bicha <jeremy.bicha@canonical.com>
+Date: Mon, 22 Aug 2022 08:31:15 -0400
+Subject: firmware-security: Disable
+
+Not yet useful enough to justify its inclusion by default here
+
+You can get the same info by running
+fwupdmgr security
+
+If you drop this patch, add a Depends: fwupd [linux-any]
+
+https://launchpad.net/bugs/1987162
+
+https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1938
+---
+ shell/cc-panel-loader.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/shell/cc-panel-loader.c b/shell/cc-panel-loader.c
+index 17f9601..1b819a5 100644
+--- a/shell/cc-panel-loader.c
++++ b/shell/cc-panel-loader.c
+@@ -113,7 +113,7 @@ static CcPanelLoaderVtable default_panels[] =
+ PANEL_TYPE("info-overview", cc_info_overview_panel_get_type, NULL),
+ PANEL_TYPE("keyboard", cc_keyboard_panel_get_type, NULL),
+ PANEL_TYPE("location", cc_location_panel_get_type, NULL),
+- PANEL_TYPE("firmware-security",cc_firmware_security_panel_get_type, cc_firmware_security_panel_static_init_func),
++ // PANEL_TYPE("firmware-security",cc_firmware_security_panel_get_type, cc_firmware_security_panel_static_init_func),
+ PANEL_TYPE("microphone", cc_microphone_panel_get_type, NULL),
+ PANEL_TYPE("mouse", cc_mouse_panel_get_type, NULL),
+ PANEL_TYPE("multitasking", cc_multitasking_panel_get_type, NULL),
diff --git a/debian/patches/keyboard-Allow-disabling-alternate-characters-key.patch b/debian/patches/keyboard-Allow-disabling-alternate-characters-key.patch
new file mode 100644
index 0000000..f3f569d
--- /dev/null
+++ b/debian/patches/keyboard-Allow-disabling-alternate-characters-key.patch
@@ -0,0 +1,32 @@
+From: Ian Douglas Scott <idscott@system76.com>
+Date: Tue, 8 Dec 2020 12:06:56 -0800
+Subject: keyboard: Allow disabling alternate characters key
+
+Support for toggling a binding was added to accommodate the compose key.
+At the time, I avoided changing the behavior of the alternate characters
+key.
+
+But it seems good to change this, which should resolve
+https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/918
+
+Origin: https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/910
+Bug-Ubuntu: https://launchpad.net/bugs/1867548
+Bug-Debian: https://bugs.debian.org/1027003
+Bug-GNOME: https://gitlab.gnome.org/GNOME/gnome-control-center/issues/918
+---
+ panels/keyboard/cc-keyboard-panel.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/panels/keyboard/cc-keyboard-panel.c b/panels/keyboard/cc-keyboard-panel.c
+index 2e91fe7..00c50ea 100644
+--- a/panels/keyboard/cc-keyboard-panel.c
++++ b/panels/keyboard/cc-keyboard-panel.c
+@@ -72,7 +72,7 @@ static const CcXkbModifier LV3_MODIFIER = {
+ { NC_("keyboard key", "Right Ctrl"), "lv3:switch" },
+ { NULL, NULL }
+ },
+- "lv3:ralt_switch",
++ NULL,
+ };
+
+ static const CcXkbModifier COMPOSE_MODIFIER = {
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..fca38fc
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,6 @@
+keyboard-Allow-disabling-alternate-characters-key.patch
+build-Look-for-snapd-glib-2.patch
+debian/Expose-touchpad-settings-if-synaptics-is-in-use.patch
+debian/Debian-s-adduser-doesn-t-allow-uppercase-letters-by-defau.patch
+debian/Ignore-result-of-test-network-panel.patch
+debian/firmware-security-disable.patch