summaryrefslogtreecommitdiffstats
path: root/tests/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/common/meson.build')
-rw-r--r--tests/common/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/common/meson.build b/tests/common/meson.build
new file mode 100644
index 0000000..0550092
--- /dev/null
+++ b/tests/common/meson.build
@@ -0,0 +1,22 @@
+
+
+test_units = [
+ 'test-hostname',
+ # 'test-time-entry', # FIXME
+]
+
+cflags = [
+ '-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir()),
+ '-DTEST_TOPSRCDIR="@0@"'.format(meson.source_root())
+]
+
+foreach unit: test_units
+ exe = executable(
+ unit,
+ unit + '.c',
+ include_directories : [ top_inc, common_inc ],
+ dependencies : common_deps + [libwidgets_dep],
+ c_args : cflags,
+ )
+ test(unit, exe)
+endforeach