summaryrefslogtreecommitdiffstats
path: root/tests/printers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/printers/meson.build')
-rw-r--r--tests/printers/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/printers/meson.build b/tests/printers/meson.build
new file mode 100644
index 0000000..60f144f
--- /dev/null
+++ b/tests/printers/meson.build
@@ -0,0 +1,22 @@
+
+test_units = [
+ #'test-canonicalization',
+ 'test-shift'
+]
+
+includes = [top_inc, include_directories('../../panels/printers')]
+cflags = '-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir())
+
+foreach unit: test_units
+ exe = executable(
+ unit,
+ [unit + '.c'],
+ include_directories : includes,
+ dependencies : common_deps,
+ link_with : [printers_panel_lib],
+ c_args : cflags
+ )
+
+ test(unit, exe)
+endforeach
+