summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:47:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:47:04 +0000
commit70dcd40a48b34179ec7a6cdf5d2ade5e7f2038f5 (patch)
tree3eec7b12c2fb81157d19bb8dc4b3fe278bbb0f28 /debian/rules
parentAdding upstream version 43.2. (diff)
downloadgnome-initial-setup-70dcd40a48b34179ec7a6cdf5d2ade5e7f2038f5.tar.xz
gnome-initial-setup-70dcd40a48b34179ec7a6cdf5d2ade5e7f2038f5.zip
Adding debian version 43.2-6.debian/43.2-6debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules39
1 files changed, 39 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..939d03e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,39 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-z,defs
+
+%:
+ dh $@
+
+# malcontent it not in Ubuntu main yet & is only built on some arches
+ifeq (yes,$(shell dpkg-vendor --derives-from Ubuntu && echo yes))
+PARENTAL_CONTROL := -Dparental_controls=disabled
+else
+ifneq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armel armhf i386 mipsel mips64el ppc64el s390x hppa hurd-i386 ppc64 riscv64))
+PARENTAL_CONTROL := -Dparental_controls=enabled
+else
+PARENTAL_CONTROL := -Dparental_controls=disabled
+endif
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -Dauto_features=enabled \
+ $(PARENTAL_CONTROL)
+
+# Skip language chooser on Ubuntu since it doesn't work there
+ifeq (yes,$(shell dpkg-vendor --derives-from Ubuntu && echo yes))
+execute_after_dh_install:
+ dh_install debian/vendor.conf /usr/share/gnome-initial-setup/
+endif
+
+# Depend on the appropriate package for the Welcome logo
+# And don't add malcontent Recommends in Ubuntu
+override_dh_gencontrol:
+ifeq (yes,$(shell dpkg-vendor --derives-from Ubuntu && echo yes))
+ dh_gencontrol -- -Vlogo:Depends='gnome-control-center-data'
+else
+ dh_gencontrol -- -Vlogo:Depends='desktop-base' \
+ -Vmalcontent:Recommends='malcontent [amd64 arm64 armel armhf i386 mips mipsel mips64el ppc64el s390x hppa powerpc powerpcspe ppc64]'
+endif