summaryrefslogtreecommitdiffstats
path: root/gnome-initial-setup/pages/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-initial-setup/pages/meson.build')
-rw-r--r--gnome-initial-setup/pages/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnome-initial-setup/pages/meson.build b/gnome-initial-setup/pages/meson.build
new file mode 100644
index 0000000..3230501
--- /dev/null
+++ b/gnome-initial-setup/pages/meson.build
@@ -0,0 +1,21 @@
+pages = [
+ 'account',
+ 'language',
+ 'keyboard',
+ 'network',
+ 'timezone',
+ 'privacy',
+ 'goa',
+ 'password',
+ 'software',
+ 'summary',
+ 'welcome',
+]
+
+if libmalcontent_dep.found() and libmalcontent_ui_dep.found()
+ pages += 'parental-controls'
+endif
+
+foreach page: pages
+ subdir (page)
+endforeach