summaryrefslogtreecommitdiffstats
path: root/plugins/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/common/meson.build')
-rw-r--r--plugins/common/meson.build43
1 files changed, 43 insertions, 0 deletions
diff --git a/plugins/common/meson.build b/plugins/common/meson.build
new file mode 100644
index 0000000..2f18c2c
--- /dev/null
+++ b/plugins/common/meson.build
@@ -0,0 +1,43 @@
+common_inc = include_directories('.')
+
+sources = files(
+ 'gsd-input-helper.c',
+ 'gsd-settings-migrate.c',
+ 'gsd-shell-helper.c'
+)
+
+resource_data = files('gtk.css')
+
+sources += gnome.compile_resources(
+ 'gsd-resources',
+ 'gsd.gresources.xml',
+ c_name: 'gsd',
+ dependencies: resource_data
+)
+
+deps = plugins_deps + [
+ gnome_desktop_dep,
+ gtk_x11_dep,
+ x11_dep,
+ dependency('kbproto'),
+ dependency('xi')
+]
+
+ldflags = []
+if host_is_darwin
+ ldflags += ['-Wl,-bundle_loader,@0@'.format(join_paths(), meson.build_root(), meson.project_name(), meson.project_name())]
+endif
+
+libcommon = static_library(
+ plugin_name,
+ sources: sources,
+ include_directories: [top_inc, data_inc],
+ dependencies: deps,
+ c_args: cflags,
+ link_args: ldflags
+)
+
+libcommon_dep = declare_dependency(
+ include_directories: common_inc,
+ link_with: libcommon
+)