summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..c921969
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+all: schemas zip
+
+0: phony
+ mkzero-gfxmonk -p impatience -p xdg gnome-shell-impatience.xml
+
+schemas: phony
+ cd impatience/schemas && glib-compile-schemas .
+
+zip: phony
+ rm -f impatience@gfxmonk.net.zip
+ cd impatience && zip -r ../impatience@gfxmonk.net.zip *
+
+.PHONY: phony