summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:54:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:54:44 +0000
commitc16cb1dcba60b0811b3c46aa4734b998a18fc8dc (patch)
tree43c388f09756344e3f0243122526bcfd61421ee9 /debian/patches
parentAdding upstream version 43.9. (diff)
downloadgnome-shell-debian.tar.xz
gnome-shell-debian.zip
Adding debian version 43.9-0+deb12u1.debian/43.9-0+deb12u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian/Revert-build-Port-to-gcr4.patch107
-rw-r--r--debian/patches/debian/gnome-shell-extension-prefs-Give-Debian-specific-advice.patch32
-rw-r--r--debian/patches/overview-Handle-unredirection-in-OverviewShown-state-mach.patch75
-rw-r--r--debian/patches/series3
4 files changed, 217 insertions, 0 deletions
diff --git a/debian/patches/debian/Revert-build-Port-to-gcr4.patch b/debian/patches/debian/Revert-build-Port-to-gcr4.patch
new file mode 100644
index 0000000..81cab65
--- /dev/null
+++ b/debian/patches/debian/Revert-build-Port-to-gcr4.patch
@@ -0,0 +1,107 @@
+From: Jeremy Bicha <jeremy.bicha@canonical.com>
+Date: Sun, 21 Aug 2022 10:30:55 -0400
+Subject: Revert "build: Port to gcr4"
+
+This reverts commit 5c935af7d3b3a3c9feb4e0d9ea214b6d25a7a2e7.
+
+Forwarded: not-needed
+---
+ js/ui/environment.js | 2 +-
+ meson.build | 4 ++--
+ src/meson.build | 2 +-
+ src/shell-keyring-prompt.c | 6 +++---
+ src/shell-secure-text-buffer.c | 2 +-
+ 5 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/js/ui/environment.js b/js/ui/environment.js
+index 8c790da..769f31c 100644
+--- a/js/ui/environment.js
++++ b/js/ui/environment.js
+@@ -8,7 +8,7 @@ imports.gi.versions.Atk = '1.0';
+ imports.gi.versions.Atspi = '2.0';
+ imports.gi.versions.Clutter = Config.LIBMUTTER_API_VERSION;
+ imports.gi.versions.Cogl = Config.LIBMUTTER_API_VERSION;
+-imports.gi.versions.Gcr = '4';
++imports.gi.versions.Gcr = '3';
+ imports.gi.versions.Gdk = '3.0';
+ imports.gi.versions.Gdm = '1.0';
+ imports.gi.versions.Geoclue = '2.0';
+diff --git a/meson.build b/meson.build
+index 1fa4311..84dba1a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -20,7 +20,7 @@ libmutter_test_pc = 'libmutter-test-' + mutter_api_version
+
+ ecal_req = '>= 3.33.1'
+ eds_req = '>= 3.33.1'
+-gcr_req = '>= 3.90.0'
++gcr_req = '>= 3.7.5'
+ gio_req = '>= 2.56.0'
+ gi_req = '>= 1.49.1'
+ gjs_req = '>= 1.73.1'
+@@ -71,7 +71,7 @@ endif
+ atk_bridge_dep = dependency('atk-bridge-2.0')
+ ecal_dep = dependency('libecal-2.0', version: ecal_req)
+ eds_dep = dependency('libedataserver-1.2', version: eds_req)
+-gcr_dep = dependency('gcr-4', version: gcr_req)
++gcr_dep = dependency('gcr-base-3', version: gcr_req)
+ gdk_x11_dep = dependency('gdk-x11-3.0')
+ gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0')
+ gi_dep = dependency('gobject-introspection-1.0', version: gi_req)
+diff --git a/src/meson.build b/src/meson.build
+index fc7f8bf..e9ad569 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -215,7 +215,7 @@ libshell_dep = declare_dependency(link_with: libshell)
+ libshell_gir_includes = [
+ 'Clutter-@0@'.format(mutter_api_version),
+ 'Meta-@0@'.format(mutter_api_version),
+- 'Gcr-4',
++ 'Gcr-3',
+ 'PolkitAgent-1.0'
+ ]
+
+diff --git a/src/shell-keyring-prompt.c b/src/shell-keyring-prompt.c
+index bb03279..83c6746 100644
+--- a/src/shell-keyring-prompt.c
++++ b/src/shell-keyring-prompt.c
+@@ -26,7 +26,7 @@
+ #include "shell-secure-text-buffer.h"
+
+ #define GCR_API_SUBJECT_TO_CHANGE
+-#include <gcr/gcr.h>
++#include <gcr/gcr-base.h>
+
+ #include <glib/gi18n.h>
+
+@@ -91,7 +91,7 @@ enum {
+
+ static GParamSpec *props[N_PROPS] = { NULL, };
+
+-static void shell_keyring_prompt_iface (GcrPromptInterface *iface);
++static void shell_keyring_prompt_iface (GcrPromptIface *iface);
+
+ G_DEFINE_TYPE_WITH_CODE (ShellKeyringPrompt, shell_keyring_prompt, G_TYPE_OBJECT,
+ G_IMPLEMENT_INTERFACE (GCR_TYPE_PROMPT, shell_keyring_prompt_iface);
+@@ -531,7 +531,7 @@ shell_keyring_prompt_close (GcrPrompt *prompt)
+ }
+
+ static void
+-shell_keyring_prompt_iface (GcrPromptInterface *iface)
++shell_keyring_prompt_iface (GcrPromptIface *iface)
+ {
+ iface->prompt_password_async = shell_keyring_prompt_password_async;
+ iface->prompt_password_finish = shell_keyring_prompt_password_finish;
+diff --git a/src/shell-secure-text-buffer.c b/src/shell-secure-text-buffer.c
+index 8271410..03af451 100644
+--- a/src/shell-secure-text-buffer.c
++++ b/src/shell-secure-text-buffer.c
+@@ -26,7 +26,7 @@
+ #include "shell-secure-text-buffer.h"
+
+ #define GCR_API_SUBJECT_TO_CHANGE
+-#include <gcr/gcr.h>
++#include <gcr/gcr-base.h>
+
+ #include <string.h>
+
diff --git a/debian/patches/debian/gnome-shell-extension-prefs-Give-Debian-specific-advice.patch b/debian/patches/debian/gnome-shell-extension-prefs-Give-Debian-specific-advice.patch
new file mode 100644
index 0000000..9759e4b
--- /dev/null
+++ b/debian/patches/debian/gnome-shell-extension-prefs-Give-Debian-specific-advice.patch
@@ -0,0 +1,32 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Sun, 12 Sep 2021 10:41:54 +0100
+Subject: gnome-shell-extension-prefs: Give Debian-specific advice
+
+We package gnome-extensions-app in the same binary package as
+gnome-shell-extension-prefs, so there's never a need to download it from
+Flathub.
+
+Forwarded: not-needed, Debian-specific
+Signed-off-by: Simon McVittie <smcv@debian.org>
+---
+ src/gnome-shell-extension-prefs | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/gnome-shell-extension-prefs b/src/gnome-shell-extension-prefs
+index 303b196..a59ffed 100755
+--- a/src/gnome-shell-extension-prefs
++++ b/src/gnome-shell-extension-prefs
+@@ -13,10 +13,10 @@ openPrefs() {
+ }
+
+ cat >&2 <<EOT
+-gnome-shell-extension-prefs is deprecated
++The gnome-shell-extension-prefs program is deprecated.
+
+-Install https://flathub.org/apps/details/org.gnome.Extensions for extension
+-management, or use the gnome-extensions command line tool.
++Run gnome-extensions-app (from the gnome-shell-extension-prefs package)
++for extension management, or use the gnome-extensions command line tool.
+
+ Extensions can use the ExtensionUtils.openPrefs() method.
+ EOT
diff --git a/debian/patches/overview-Handle-unredirection-in-OverviewShown-state-mach.patch b/debian/patches/overview-Handle-unredirection-in-OverviewShown-state-mach.patch
new file mode 100644
index 0000000..fbd4061
--- /dev/null
+++ b/debian/patches/overview-Handle-unredirection-in-OverviewShown-state-mach.patch
@@ -0,0 +1,75 @@
+From: "robert.mader@collabora.com" <robert.mader@collabora.com>
+Date: Wed, 27 Sep 2023 01:10:45 +0200
+Subject: overview: Handle unredirection in OverviewShown state machine
+
+Under certain unknown circumstances currently not every
+`disable_unredirect_for_display()` gets matched with an
+`enable_unredirect_for_display()` when closing the overview.
+
+As we only want to not disable unredirection when hidden and we nowadays
+have a state machine that ensures we transition to and from one state to
+another only once, handle unredirection en-/disablement as part of the
+state transition.
+
+(cherry picked from commit a94fcee9616ef52d0f1d6453515a104d69c6cb92)
+
+Bug: https://gitlab.gnome.org/GNOME/mutter/-/issues/2994
+Origin: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/2970
+Applied-upstream: 43.10, commit:3b921ba0cb28c38ff5b7faba2dfe446cbc845bb4
+---
+ js/ui/overview.js | 14 +++++---------
+ 1 file changed, 5 insertions(+), 9 deletions(-)
+
+diff --git a/js/ui/overview.js b/js/ui/overview.js
+index 757a8e4..bf3ffca 100644
+--- a/js/ui/overview.js
++++ b/js/ui/overview.js
+@@ -296,6 +296,11 @@ var Overview = class extends Signals.EventEmitter {
+ `${this._shownState} to ${state}`);
+ }
+
++ if (this._shownState === OverviewShownState.HIDDEN)
++ Meta.disable_unredirect_for_display(global.display);
++ else if (state === OverviewShownState.HIDDEN)
++ Meta.enable_unredirect_for_display(global.display);
++
+ this._shownState = state;
+ this.emit(OVERVIEW_SHOWN_TRANSITIONS[state].signal);
+ }
+@@ -402,8 +407,6 @@ var Overview = class extends Signals.EventEmitter {
+
+ _gestureUpdate(tracker, progress) {
+ if (!this._shown) {
+- Meta.disable_unredirect_for_display(global.display);
+-
+ this._shown = true;
+ this._visible = true;
+ this._visibleTarget = true;
+@@ -559,8 +562,6 @@ var Overview = class extends Signals.EventEmitter {
+ this._visibleTarget = true;
+ this._activationTime = GLib.get_monotonic_time() / GLib.USEC_PER_SEC;
+
+- Meta.disable_unredirect_for_display(global.display);
+-
+ Main.layoutManager.overviewGroup.set_child_above_sibling(
+ this._coverPane, null);
+ this._coverPane.show();
+@@ -627,9 +628,6 @@ var Overview = class extends Signals.EventEmitter {
+ }
+
+ _hideDone() {
+- // Re-enable unredirection
+- Meta.enable_unredirect_for_display(global.display);
+-
+ this._coverPane.hide();
+
+ this._visible = false;
+@@ -679,8 +677,6 @@ var Overview = class extends Signals.EventEmitter {
+ // the animation because of a race in the xserver where the grab
+ // fails when requested very early during startup.
+
+- Meta.disable_unredirect_for_display(global.display);
+-
+ this._changeShownState(OverviewShownState.SHOWING);
+
+ this._overview.runStartupAnimation(() => {
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..917d008
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+overview-Handle-unredirection-in-OverviewShown-state-mach.patch
+debian/gnome-shell-extension-prefs-Give-Debian-specific-advice.patch
+debian/Revert-build-Port-to-gcr4.patch