summaryrefslogtreecommitdiffstats
path: root/subprojects/shew/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/shew/meson.build')
-rw-r--r--subprojects/shew/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/subprojects/shew/meson.build b/subprojects/shew/meson.build
new file mode 100644
index 0000000..58a2499
--- /dev/null
+++ b/subprojects/shew/meson.build
@@ -0,0 +1,28 @@
+project('shew', 'c',
+ version: '43.9',
+ meson_version: '>= 0.58.0',
+ license: 'LGPLv2+',
+)
+
+assert(meson.is_subproject(), 'This project is only intended to be used as a subproject!')
+
+gnome = import('gnome')
+pkg = import('pkgconfig')
+
+api_version = '0'
+full_name = '@0@-@1@'.format(meson.project_name(), api_version)
+
+package_version = meson.project_version()
+package_name = get_option('package_name')
+assert(package_name != '', 'package_name must be specified')
+
+pkgdatadir = join_paths(get_option('datadir'), package_name)
+pkglibdir = join_paths(get_option('libdir'), package_name)
+
+girdir = join_paths(pkgdatadir, 'gir-1.0')
+typelibdir = join_paths(pkglibdir, 'girepository-1.0')
+
+gtk_dep = dependency('gtk4')
+x11_dep = dependency('x11', required: false)
+
+subdir('src')