summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..9d3925d
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,29 @@
+testconf = configuration_data()
+testconf.set('MUTTER_TYPELIB_DIR', mutter_typelibdir)
+testconf.set('srcdir', meson.current_source_dir())
+run_test = configure_file(
+ input: 'run-test.sh.in',
+ output: 'run-test.sh',
+ configuration: testconf
+)
+
+testenv = environment()
+testenv.set('GSETTINGS_SCHEMA_DIR', join_paths(meson.project_build_root(), 'data'))
+
+tests = [
+ 'highlighter',
+ 'insertSorted',
+ 'jsParse',
+ 'markup',
+ 'params',
+ 'signalTracker',
+ 'url',
+ 'versionCompare',
+]
+
+foreach test : tests
+ test(test, run_test,
+ args: 'unit/@0@.js'.format(test),
+ env: testenv,
+ workdir: meson.current_source_dir())
+endforeach