summaryrefslogtreecommitdiffstats
path: root/plugins/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:57:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:57:27 +0000
commit6f0f7d1b40a8fa8d46a2d6f4317600001cdbbb18 (patch)
treed423850ae901365e582137bdf2b5cbdffd7ca266 /plugins/meson.build
parentInitial commit. (diff)
downloadgnome-software-upstream.tar.xz
gnome-software-upstream.zip
Adding upstream version 43.5.upstream/43.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plugins/meson.build')
-rw-r--r--plugins/meson.build43
1 files changed, 43 insertions, 0 deletions
diff --git a/plugins/meson.build b/plugins/meson.build
new file mode 100644
index 0000000..711b488
--- /dev/null
+++ b/plugins/meson.build
@@ -0,0 +1,43 @@
+plugin_dir = join_paths(gs_private_libdir, 'plugins-' + gs_plugin_api_version)
+plugin_libs = [
+ appstream,
+ gio_unix,
+ json_glib,
+ libsoup,
+ libgnomesoftware_dep,
+]
+
+subdir('core')
+subdir('dpkg')
+subdir('dummy')
+subdir('fedora-langpacks')
+subdir('fedora-pkgdb-collections')
+
+if get_option('eos_updater')
+ subdir('eos-updater')
+endif
+if get_option('flatpak')
+ subdir('flatpak')
+endif
+if get_option('fwupd')
+ subdir('fwupd')
+endif
+if get_option('gudev')
+ subdir('modalias')
+endif
+if get_option('malcontent')
+ subdir('malcontent')
+endif
+if get_option('packagekit')
+ subdir('packagekit')
+endif
+subdir('repos')
+if get_option('rpm_ostree')
+ subdir('rpm-ostree')
+endif
+if get_option('snap')
+ subdir('snap')
+endif
+if get_option('webapps')
+ subdir('epiphany')
+endif