summaryrefslogtreecommitdiffstats
path: root/plugins/modalias
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:57:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:57:27 +0000
commit6f0f7d1b40a8fa8d46a2d6f4317600001cdbbb18 (patch)
treed423850ae901365e582137bdf2b5cbdffd7ca266 /plugins/modalias
parentInitial commit. (diff)
downloadgnome-software-6f0f7d1b40a8fa8d46a2d6f4317600001cdbbb18.tar.xz
gnome-software-6f0f7d1b40a8fa8d46a2d6f4317600001cdbbb18.zip
Adding upstream version 43.5.upstream/43.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plugins/modalias')
-rw-r--r--plugins/modalias/gs-plugin-modalias.c199
-rw-r--r--plugins/modalias/gs-plugin-modalias.h22
-rw-r--r--plugins/modalias/gs-self-test.c113
-rw-r--r--plugins/modalias/meson.build36
4 files changed, 370 insertions, 0 deletions
diff --git a/plugins/modalias/gs-plugin-modalias.c b/plugins/modalias/gs-plugin-modalias.c
new file mode 100644
index 0000000..9efbcf1
--- /dev/null
+++ b/plugins/modalias/gs-plugin-modalias.c
@@ -0,0 +1,199 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*-
+ * vi:set noexpandtab tabstop=8 shiftwidth=8:
+ *
+ * Copyright (C) 2016 Richard Hughes <richard@hughsie.com>
+ *
+ * SPDX-License-Identifier: GPL-2.0+
+ */
+
+#include <config.h>
+
+#include <fnmatch.h>
+#include <gudev/gudev.h>
+
+#include <gnome-software.h>
+
+#include "gs-plugin-modalias.h"
+
+struct _GsPluginModalias {
+ GsPlugin parent;
+
+ GUdevClient *client;
+ GPtrArray *devices;
+};
+
+G_DEFINE_TYPE (GsPluginModalias, gs_plugin_modalias, GS_TYPE_PLUGIN)
+
+static void
+gs_plugin_modalias_uevent_cb (GUdevClient *client,
+ const gchar *action,
+ GUdevDevice *device,
+ gpointer user_data)
+{
+ GsPluginModalias *self = GS_PLUGIN_MODALIAS (user_data);
+
+ if (g_strcmp0 (action, "add") == 0 ||
+ g_strcmp0 (action, "remove") == 0) {
+ g_debug ("invalidating devices as '%s' sent action '%s'",
+ g_udev_device_get_sysfs_path (device),
+ action);
+ g_ptr_array_set_size (self->devices, 0);
+ }
+}
+
+static void
+gs_plugin_modalias_init (GsPluginModalias *self)
+{
+ GsPlugin *plugin = GS_PLUGIN (self);
+
+ gs_plugin_add_rule (plugin, GS_PLUGIN_RULE_RUN_AFTER, "appstream");
+ gs_plugin_add_rule (plugin, GS_PLUGIN_RULE_RUN_BEFORE, "icons");
+
+ self->devices = g_ptr_array_new_with_free_func ((GDestroyNotify) g_object_unref);
+ self->client = g_udev_client_new (NULL);
+ g_signal_connect (self->client, "uevent",
+ G_CALLBACK (gs_plugin_modalias_uevent_cb), self);
+}
+
+static void
+gs_plugin_modalias_dispose (GObject *object)
+{
+ GsPluginModalias *self = GS_PLUGIN_MODALIAS (object);
+
+ g_clear_object (&self->client);
+ g_clear_pointer (&self->devices, g_ptr_array_unref);
+
+ G_OBJECT_CLASS (gs_plugin_modalias_parent_class)->dispose (object);
+}
+
+static void
+gs_plugin_modalias_ensure_devices (GsPluginModalias *self)
+{
+ g_autoptr(GList) list = NULL;
+
+ /* already set */
+ if (self->devices->len > 0)
+ return;
+
+ /* get the devices, and assume ownership of each */
+ list = g_udev_client_query_by_subsystem (self->client, NULL);
+ for (GList *l = list; l != NULL; l = l->next) {
+ GUdevDevice *device = G_UDEV_DEVICE (l->data);
+ if (g_udev_device_get_sysfs_attr (device, "modalias") == NULL) {
+ g_object_unref (device);
+ continue;
+ }
+ g_ptr_array_add (self->devices, device);
+ }
+ g_debug ("%u devices with modalias", self->devices->len);
+}
+
+static gboolean
+gs_plugin_modalias_matches (GsPluginModalias *self,
+ const gchar *modalias)
+{
+ gs_plugin_modalias_ensure_devices (self);
+ for (guint i = 0; i < self->devices->len; i++) {
+ GUdevDevice *device = g_ptr_array_index (self->devices, i);
+ const gchar *modalias_tmp;
+
+ /* get the (optional) device modalias */
+ modalias_tmp = g_udev_device_get_sysfs_attr (device, "modalias");
+ if (modalias_tmp == NULL)
+ continue;
+ if (fnmatch (modalias, modalias_tmp, 0) == 0) {
+ g_debug ("matched %s against %s", modalias_tmp, modalias);
+ return TRUE;
+ }
+ }
+ return FALSE;
+}
+
+static gboolean
+refine_app (GsPluginModalias *self,
+ GsApp *app,
+ GsPluginRefineFlags flags,
+ GCancellable *cancellable,
+ GError **error)
+{
+ GPtrArray *provided;
+ guint i;
+
+ /* not required */
+ if (gs_app_get_icons (app) != NULL)
+ return TRUE;
+ if (gs_app_get_kind (app) != AS_COMPONENT_KIND_DRIVER)
+ return TRUE;
+
+ /* do any of the modaliases match any installed hardware */
+ provided = gs_app_get_provided (app);
+ for (i = 0 ; i < provided->len; i++) {
+ GPtrArray *items;
+ AsProvided *prov = g_ptr_array_index (provided, i);
+ if (as_provided_get_kind (prov) != AS_PROVIDED_KIND_MODALIAS)
+ continue;
+ items = as_provided_get_items (prov);
+ for (guint j = 0; j < items->len; j++) {
+ if (gs_plugin_modalias_matches (self, (const gchar*) g_ptr_array_index (items, j))) {
+ g_autoptr(GIcon) ic = NULL;
+ ic = g_themed_icon_new ("emblem-system-symbolic");
+ gs_app_add_icon (app, ic);
+ gs_app_add_quirk (app, GS_APP_QUIRK_NOT_LAUNCHABLE);
+ break;
+ }
+ }
+ }
+ return TRUE;
+}
+
+static void
+gs_plugin_modalias_refine_async (GsPlugin *plugin,
+ GsAppList *list,
+ GsPluginRefineFlags flags,
+ GCancellable *cancellable,
+ GAsyncReadyCallback callback,
+ gpointer user_data)
+{
+ GsPluginModalias *self = GS_PLUGIN_MODALIAS (plugin);
+ g_autoptr(GTask) task = NULL;
+ g_autoptr(GError) local_error = NULL;
+
+ task = g_task_new (plugin, cancellable, callback, user_data);
+ g_task_set_source_tag (task, gs_plugin_modalias_refine_async);
+
+ for (guint i = 0; i < gs_app_list_length (list); i++) {
+ GsApp *app = gs_app_list_index (list, i);
+ if (!refine_app (self, app, flags, cancellable, &local_error)) {
+ g_task_return_error (task, g_steal_pointer (&local_error));
+ return;
+ }
+ }
+
+ g_task_return_boolean (task, TRUE);
+}
+
+static gboolean
+gs_plugin_modalias_refine_finish (GsPlugin *plugin,
+ GAsyncResult *result,
+ GError **error)
+{
+ return g_task_propagate_boolean (G_TASK (result), error);
+}
+
+static void
+gs_plugin_modalias_class_init (GsPluginModaliasClass *klass)
+{
+ GObjectClass *object_class = G_OBJECT_CLASS (klass);
+ GsPluginClass *plugin_class = GS_PLUGIN_CLASS (klass);
+
+ object_class->dispose = gs_plugin_modalias_dispose;
+
+ plugin_class->refine_async = gs_plugin_modalias_refine_async;
+ plugin_class->refine_finish = gs_plugin_modalias_refine_finish;
+}
+
+GType
+gs_plugin_query_type (void)
+{
+ return GS_TYPE_PLUGIN_MODALIAS;
+}
diff --git a/plugins/modalias/gs-plugin-modalias.h b/plugins/modalias/gs-plugin-modalias.h
new file mode 100644
index 0000000..386a667
--- /dev/null
+++ b/plugins/modalias/gs-plugin-modalias.h
@@ -0,0 +1,22 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*-
+ * vi:set noexpandtab tabstop=8 shiftwidth=8:
+ *
+ * Copyright (C) 2021 Endless OS Foundation LLC
+ *
+ * Author: Philip Withnall <pwithnall@endlessos.org>
+ *
+ * SPDX-License-Identifier: GPL-2.0+
+ */
+
+#pragma once
+
+#include <glib.h>
+#include <glib-object.h>
+
+G_BEGIN_DECLS
+
+#define GS_TYPE_PLUGIN_MODALIAS (gs_plugin_modalias_get_type ())
+
+G_DECLARE_FINAL_TYPE (GsPluginModalias, gs_plugin_modalias, GS, PLUGIN_MODALIAS, GsPlugin)
+
+G_END_DECLS
diff --git a/plugins/modalias/gs-self-test.c b/plugins/modalias/gs-self-test.c
new file mode 100644
index 0000000..e2c59da
--- /dev/null
+++ b/plugins/modalias/gs-self-test.c
@@ -0,0 +1,113 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*-
+ * vi:set noexpandtab tabstop=8 shiftwidth=8:
+ *
+ * Copyright (C) 2013-2017 Richard Hughes <richard@hughsie.com>
+ *
+ * SPDX-License-Identifier: GPL-2.0+
+ */
+
+#include "config.h"
+
+#include "gnome-software-private.h"
+
+#include "gs-test.h"
+
+static void
+gs_plugins_modalias_func (GsPluginLoader *plugin_loader)
+{
+ GsApp *app;
+ g_autoptr(GError) error = NULL;
+ g_autoptr(GsAppList) list = NULL;
+ g_autoptr(GsAppQuery) query = NULL;
+ const gchar *keywords[2] = { NULL, };
+ g_autoptr(GsPluginJob) plugin_job = NULL;
+
+ /* get search result based on addon keyword */
+ keywords[0] = "colorhug2";
+ query = gs_app_query_new ("keywords", keywords,
+ "refine-flags", GS_PLUGIN_REFINE_FLAGS_REQUIRE_CATEGORIES,
+ "dedupe-flags", GS_PLUGIN_JOB_DEDUPE_FLAGS_DEFAULT,
+ "sort-func", gs_utils_app_sort_match_value,
+ NULL);
+ plugin_job = gs_plugin_job_list_apps_new (query, GS_PLUGIN_LIST_APPS_FLAGS_NONE);
+ list = gs_plugin_loader_job_process (plugin_loader, plugin_job, NULL, &error);
+ gs_test_flush_main_context ();
+ g_assert_no_error (error);
+ g_assert (list != NULL);
+
+ /* make sure there is one entry, the parent app */
+ g_assert_cmpint (gs_app_list_length (list), ==, 1);
+ app = gs_app_list_index (list, 0);
+ g_assert_cmpstr (gs_app_get_id (app), ==, "com.hughski.ColorHug2.driver");
+ g_assert_cmpint (gs_app_get_kind (app), ==, AS_COMPONENT_KIND_DRIVER);
+ g_assert (gs_app_has_category (app, "Addon"));
+ g_assert (gs_app_has_category (app, "Driver"));
+}
+
+int
+main (int argc, char **argv)
+{
+ g_autofree gchar *tmp_root = NULL;
+ gboolean ret;
+ int retval;
+ g_autofree gchar *xml = NULL;
+ g_autoptr(GError) error = NULL;
+ g_autoptr(GsPluginLoader) plugin_loader = NULL;
+ const gchar * const allowlist[] = {
+ "appstream",
+ "dummy",
+ "modalias",
+ NULL
+ };
+
+ gs_test_init (&argc, &argv);
+ g_setenv ("GS_SELF_TEST_DUMMY_ENABLE", "1", TRUE);
+
+ xml = g_strdup_printf ("<?xml version=\"1.0\"?>\n"
+ "<components version=\"0.9\">\n"
+ " <component type=\"driver\">\n"
+ " <id>com.hughski.ColorHug2.driver</id>\n"
+ " <name>ColorHug2</name>\n"
+ " <summary>ColorHug2 Colorimeter Driver</summary>\n"
+ " <pkgname>colorhug-client</pkgname>\n"
+ " <provides>\n"
+ " <modalias>pci:*</modalias>\n"
+ " </provides>\n"
+ " </component>\n"
+ " <info>\n"
+ " <scope>system</scope>\n"
+ " </info>\n"
+ "</components>\n");
+ g_setenv ("GS_SELF_TEST_APPSTREAM_XML", xml, TRUE);
+
+ /* Use a common cache directory for all tests, since the appstream
+ * plugin uses it and cannot be reinitialised for each test. */
+ tmp_root = g_dir_make_tmp ("gnome-software-modalias-test-XXXXXX", NULL);
+ g_assert (tmp_root != NULL);
+ g_setenv ("GS_SELF_TEST_CACHEDIR", tmp_root, TRUE);
+
+ /* we can only load this once per process */
+ plugin_loader = gs_plugin_loader_new (NULL, NULL);
+ gs_plugin_loader_add_location (plugin_loader, LOCALPLUGINDIR);
+ gs_plugin_loader_add_location (plugin_loader, LOCALPLUGINDIR_CORE);
+ gs_plugin_loader_add_location (plugin_loader, LOCALPLUGINDIR_DUMMY);
+ ret = gs_plugin_loader_setup (plugin_loader,
+ allowlist,
+ NULL,
+ NULL,
+ &error);
+ g_assert_no_error (error);
+ g_assert (ret);
+
+ /* plugin tests go here */
+ g_test_add_data_func ("/gnome-software/plugins/modalias",
+ plugin_loader,
+ (GTestDataFunc) gs_plugins_modalias_func);
+
+ retval = g_test_run ();
+
+ /* Clean up. */
+ gs_utils_rmtree (tmp_root, NULL);
+
+ return retval;
+}
diff --git a/plugins/modalias/meson.build b/plugins/modalias/meson.build
new file mode 100644
index 0000000..fc0c806
--- /dev/null
+++ b/plugins/modalias/meson.build
@@ -0,0 +1,36 @@
+cargs = ['-DG_LOG_DOMAIN="GsPluginModalias"']
+cargs += ['-DLOCALPLUGINDIR="' + meson.current_build_dir() + '"']
+cargs += ['-DLOCALPLUGINDIR_CORE="' + meson.current_build_dir() + '/../core"']
+cargs += ['-DLOCALPLUGINDIR_DUMMY="' + meson.current_build_dir() + '/../dummy"']
+
+shared_module(
+ 'gs_plugin_modalias',
+sources : 'gs-plugin-modalias.c',
+ include_directories : [
+ include_directories('../..'),
+ include_directories('../../lib'),
+ ],
+ install : true,
+ install_dir: plugin_dir,
+ c_args : cargs,
+ dependencies : [ plugin_libs, gudev ],
+)
+
+if get_option('tests')
+ e = executable(
+ 'gs-self-test-modalias',
+ compiled_schemas,
+ sources : [
+ 'gs-self-test.c'
+ ],
+ include_directories : [
+ include_directories('../..'),
+ include_directories('../../lib'),
+ ],
+ dependencies : [
+ plugin_libs,
+ ],
+ c_args : cargs,
+ )
+ test('gs-self-test-modalias', e, suite: ['plugins', 'modalias'], env: test_env)
+endif