summaryrefslogtreecommitdiffstats
path: root/contrib
diff options
context:
space:
mode:
Diffstat (limited to 'contrib')
-rw-r--r--contrib/deployment-featured.ini4
-rw-r--r--contrib/gnome-software.spec.in190
-rw-r--r--contrib/org.gnome.Software.DeploymentFeatured.xml11
-rw-r--r--contrib/org.gnome.SoftwareDevel.json214
4 files changed, 419 insertions, 0 deletions
diff --git a/contrib/deployment-featured.ini b/contrib/deployment-featured.ini
new file mode 100644
index 0000000..3134130
--- /dev/null
+++ b/contrib/deployment-featured.ini
@@ -0,0 +1,4 @@
+[Deployment Featured Apps]
+Selector=foocorp
+Title=Featured by Foo Corp.
+Title[it]=Presentato da Foo Corp.
diff --git a/contrib/gnome-software.spec.in b/contrib/gnome-software.spec.in
new file mode 100644
index 0000000..6266107
--- /dev/null
+++ b/contrib/gnome-software.spec.in
@@ -0,0 +1,190 @@
+%global glib2_version 2.61.1
+%global gtk3_version 3.22.4
+%global json_glib_version 1.6.0
+%global packagekit_version 1.1.1
+%global appstream_version 0.14.0
+%global libsoup_version 2.52.0
+%global gsettings_desktop_schemas_version 3.12.0
+%global fwupd_version 1.2.10
+%global flatpak_version 1.1.3
+%global libxmlb_version 0.1.7
+
+%define alphatag #ALPHATAG#
+
+Name: gnome-software
+Version: #VERSION#
+Release: 0.#BUILD#%{?alphatag}%{?dist}
+Summary: A software center for GNOME
+
+License: GPLv2+
+URL: https://wiki.gnome.org/Apps/Software
+Source0: https://download.gnome.org/sources/gnome-software/3.34/%{name}-%{version}.tar.xz
+
+BuildRequires: gcc
+BuildRequires: gettext
+BuildRequires: libxslt
+BuildRequires: docbook-style-xsl
+BuildRequires: desktop-file-utils
+BuildRequires: fwupd-devel >= %{fwupd_version}
+BuildRequires: glib2-devel >= %{glib2_version}
+BuildRequires: gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_version}
+BuildRequires: gtk3-devel >= %{gtk3_version}
+BuildRequires: gtk-doc
+BuildRequires: json-glib-devel >= %{json_glib_version}
+BuildRequires: libappstream-devel >= %{appstream_version}
+BuildRequires: libdnf-devel
+BuildRequires: libsoup-devel
+BuildRequires: libxmlb-devel >= %{libxmlb_version}
+BuildRequires: meson
+BuildRequires: PackageKit-glib-devel >= %{packagekit_version}
+BuildRequires: polkit-devel
+BuildRequires: flatpak-devel >= %{flatpak_version}
+BuildRequires: ostree-devel
+BuildRequires: rpm-devel
+BuildRequires: rpm-ostree-devel
+BuildRequires: libgudev1-devel
+
+Requires: appstream-data
+Requires: flatpak%{?_isa} >= %{flatpak_version}
+Requires: flatpak-libs%{?_isa} >= %{flatpak_version}
+Requires: fwupd%{?_isa} >= %{fwupd_version}
+Requires: glib2%{?_isa} >= %{glib2_version}
+# gnome-menus is needed for app folder .directory entries
+Requires: gnome-menus%{?_isa}
+Requires: gsettings-desktop-schemas%{?_isa} >= %{gsettings_desktop_schemas_version}
+Requires: gtk3%{?_isa} >= %{gtk3_version}
+Requires: json-glib%{?_isa} >= %{json_glib_version}
+Requires: iso-codes
+Requires: libappstream%{?_isa} >= %{appstream_version}
+# librsvg2 is needed for gdk-pixbuf svg loader
+Requires: librsvg2%{?_isa}
+Requires: libsoup%{?_isa} >= %{libsoup_version}
+Requires: libxmlb%{?_isa} >= %{libxmlb_version}
+
+Recommends: PackageKit%{?_isa} >= %{packagekit_version}
+
+Obsoletes: gnome-software-snap < 3.33.1
+Obsoletes: gnome-software-editor < 3.35.1
+
+# this is not a library version
+%define gs_plugin_version 16
+%define gs_plugin_dir %{_libdir}/gnome-software/plugins-%{gs_plugin_version}
+
+%description
+gnome-software is an application that makes it easy to add, remove
+and update software in the GNOME desktop.
+
+%package devel
+Summary: Headers for building external gnome-software plugins
+Requires: %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+These development files are for building gnome-software plugins outside
+the source tree. Most users do not need this subpackage installed.
+
+%package rpm-ostree
+Summary: rpm-ostree backend for gnome-software
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: rpm-ostree%{?_isa}
+Supplements: (gnome-software%{?_isa} and rpm-ostree%{?_isa})
+
+%description rpm-ostree
+gnome-software is an application that makes it easy to add, remove
+and update software in the GNOME desktop.
+
+This package includes the rpm-ostree backend.
+
+%prep
+%autosetup -p1
+
+%build
+%meson \
+ -Dsnap=false \
+ -Dgudev=true \
+ -Dpackagekit=true \
+ -Dexternal_appstream=false \
+ -Drpm_ostree=true \
+ -Dtests=false
+%meson_build
+
+%install
+%meson_install
+
+# remove unneeded dpkg plugin
+rm %{buildroot}%{gs_plugin_dir}/libgs_plugin_dpkg.so
+
+# make the software center load faster
+desktop-file-edit %{buildroot}%{_datadir}/applications/org.gnome.Software.desktop \
+ --set-key=X-AppInstall-Package --set-value=%{name}
+
+# set up for Fedora
+cat >> %{buildroot}%{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override << FOE
+[org.gnome.software]
+official-repos = [ 'anaconda', 'fedora', 'fedora-debuginfo', 'fedora-source', 'koji-override-0', 'koji-override-1', 'rawhide', 'rawhide-debuginfo', 'rawhide-source', 'updates', 'updates-debuginfo', 'updates-source', 'updates-testing', 'updates-testing-debuginfo', 'updates-testing-source', 'fedora-modular', 'fedora-modular-debuginfo', 'fedora-modular-source', 'rawhide-modular', 'rawhide-modular-debuginfo', 'rawhide-modular-source' ]
+FOE
+
+%find_lang %name --with-gnome
+
+%check
+desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
+
+%files -f %{name}.lang
+%doc AUTHORS README.md
+%license COPYING
+%{_bindir}/gnome-software
+%{_datadir}/applications/gnome-software-local-file-flatpak.desktop
+%{_datadir}/applications/gnome-software-local-file-fwupd.desktop
+%{_datadir}/applications/gnome-software-local-file-packagekit.desktop
+%{_datadir}/applications/org.gnome.Software.desktop
+%dir %{_datadir}/gnome-software
+%{_datadir}/gnome-software/*.png
+%{_mandir}/man1/gnome-software.1.gz
+%{_datadir}/icons/hicolor/*/apps/org.gnome.Software.svg
+%{_datadir}/icons/hicolor/symbolic/apps/org.gnome.Software-symbolic.svg
+%{_datadir}/gnome-software/featured-*.svg
+%{_datadir}/gnome-software/featured-*.jpg
+%{_datadir}/metainfo/org.gnome.Software.metainfo.xml
+%{_datadir}/metainfo/org.gnome.Software.Plugin.Epiphany.metainfo.xml
+%{_datadir}/metainfo/org.gnome.Software.Plugin.Flatpak.metainfo.xml
+%{_datadir}/metainfo/org.gnome.Software.Plugin.Fwupd.metainfo.xml
+%dir %{gs_plugin_dir}
+%{gs_plugin_dir}/libgs_plugin_appstream.so
+%{gs_plugin_dir}/libgs_plugin_dummy.so
+%{gs_plugin_dir}/libgs_plugin_epiphany.so
+%{gs_plugin_dir}/libgs_plugin_fedora-langpacks.so
+%{gs_plugin_dir}/libgs_plugin_fedora-pkgdb-collections.so
+%{gs_plugin_dir}/libgs_plugin_flatpak.so
+%{gs_plugin_dir}/libgs_plugin_fwupd.so
+%{gs_plugin_dir}/libgs_plugin_generic-updates.so
+%{gs_plugin_dir}/libgs_plugin_hardcoded-blocklist.so
+%{gs_plugin_dir}/libgs_plugin_icons.so
+%{gs_plugin_dir}/libgs_plugin_modalias.so
+%{gs_plugin_dir}/libgs_plugin_os-release.so
+%{gs_plugin_dir}/libgs_plugin_packagekit.so
+%{gs_plugin_dir}/libgs_plugin_provenance-license.so
+%{gs_plugin_dir}/libgs_plugin_provenance.so
+%{gs_plugin_dir}/libgs_plugin_repos.so
+%{gs_plugin_dir}/libgs_plugin_rewrite-resource.so
+%{_sysconfdir}/xdg/autostart/org.gnome.Software.desktop
+%{_datadir}/app-info/xmls/org.gnome.Software.Featured.xml
+%{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
+%{_datadir}/dbus-1/services/org.gnome.Software.service
+%{_datadir}/gnome-shell/search-providers/org.gnome.Software-search-provider.ini
+%{_datadir}/glib-2.0/schemas/org.gnome.software.gschema.xml
+%{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override
+%{_libexecdir}/gnome-software-cmd
+%{_libexecdir}/gnome-software-restarter
+
+%files rpm-ostree
+%{gs_plugin_dir}/libgs_plugin_rpm-ostree.so
+
+%files devel
+%{_libdir}/pkgconfig/gnome-software.pc
+%dir %{_includedir}/gnome-software
+%{_includedir}/gnome-software/*.h
+%{_datadir}/gtk-doc/html/gnome-software
+
+%changelog
+* #LONGDATE# Richard Hughes <richard@hughsie.com> #VERSION#-0.#BUILD##ALPHATAG#
+- Update from GIT
+
diff --git a/contrib/org.gnome.Software.DeploymentFeatured.xml b/contrib/org.gnome.Software.DeploymentFeatured.xml
new file mode 100644
index 0000000..520f19a
--- /dev/null
+++ b/contrib/org.gnome.Software.DeploymentFeatured.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- This is only an example file, what the deployment-featured file can look like;
+ if used, it should be installed beside the org.gnome.Software.Featured.xml file. -->
+<components>
+ <component merge="append">
+ <id>org.gnome.Software.desktop</id>
+ <custom>
+ <value key="GnomeSoftware::DeploymentFeatured">foocorp</value>
+ </custom>
+ </component>
+</components>
diff --git a/contrib/org.gnome.SoftwareDevel.json b/contrib/org.gnome.SoftwareDevel.json
new file mode 100644
index 0000000..577aef7
--- /dev/null
+++ b/contrib/org.gnome.SoftwareDevel.json
@@ -0,0 +1,214 @@
+{
+ "app-id": "org.gnome.SoftwareDevel",
+ "runtime": "org.gnome.Platform",
+ "runtime-version": "master",
+ "sdk": "org.gnome.Sdk",
+ "command": "gnome-software",
+ "tags": [
+ "devel",
+ "development",
+ "nightly"
+ ],
+ "finish-args": [
+ "--device=dri",
+ "--share=ipc",
+ "--socket=x11",
+ "--socket=wayland",
+ "--socket=session-bus",
+ "--socket=system-bus",
+ "--filesystem=host",
+ "--share=network",
+ "--filesystem=xdg-run/dconf",
+ "--filesystem=~/.config/dconf:ro",
+ "--talk-name=ca.desrt.dconf",
+ "--env=DCONF_USER_CONFIG_DIR=.config/dconf",
+ "--filesystem=/var/lib/flatpak",
+ "--env=FLATPAK_SYSTEM_DIR=/var/lib/flatpak",
+ "--filesystem=xdg-data/flatpak",
+ "--filesystem=/usr/share/metainfo:ro",
+ "--filesystem=/usr/share/swcatalog:ro",
+ "--filesystem=/usr/share/appdata:ro",
+ "--filesystem=/usr/share/app-info:ro",
+ "--filesystem=/var/lib/swcatalog:ro",
+ "--filesystem=/var/lib/app-info:ro",
+ "--filesystem=/var/cache/swcatalog:ro",
+ "--filesystem=/var/cache/app-info:ro"
+ ],
+ "modules": [
+ {
+ "name": "libyaml",
+ "buildsystem": "autotools",
+ "builddir": true,
+ "config-opts": [
+ "--libdir=/app/lib"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://github.com/yaml/libyaml"
+ }
+ ]
+ },
+ {
+ "name": "lmdb",
+ "buildsystem": "simple",
+ "subdir": "libraries/liblmdb",
+ "build-commands": [
+ "make install prefix=/ DESTDIR=/app"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://git.openldap.org/openldap/openldap.git"
+ }
+ ]
+ },
+ {
+ "name": "libxmlb",
+ "buildsystem": "meson",
+ "config-opts": [
+ "-Dgtkdoc=false"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://github.com/hughsie/libxmlb.git",
+ "branch": "main"
+ }
+ ]
+ },
+ {
+ "name": "appstream",
+ "buildsystem": "meson",
+ "config-opts": [
+ "-Dstemming=false",
+ "-Dapidocs=false"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://github.com/ximion/appstream.git",
+ "tag": "v0.15.2",
+ "commit": "d2bfe7c2a4ca692daf33a5cb4d429011269d1cba"
+ }
+ ]
+ },
+ {
+ "name": "intltool",
+ "buildsystem": "autotools",
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://download.gnome.org/sources/intltool/0.40/intltool-0.40.6.tar.bz2",
+ "sha256": "4d1e5f8561f09c958e303d4faa885079a5e173a61d28437d0013ff5efc9e3b64"
+ }
+ ]
+ },
+ {
+ "name": "linux-pam",
+ "buildsystem": "autotools",
+ "config-opts": [
+ "--disable-doc",
+ "--includedir=/app/include/security"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://github.com/linux-pam/linux-pam.git"
+ }
+ ]
+ },
+ {
+ "name": "polkit",
+ "buildsystem": "meson",
+ "config-opts": [
+ "-Djs_engine=mozjs"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://gitlab.freedesktop.org/polkit/polkit.git"
+ }
+ ]
+ },
+ {
+ "name": "libfuse",
+ "buildsystem": "simple",
+ "build-commands": [
+ "./makeconf.sh",
+ "./configure --disable-util --disable-example --prefix=/",
+ "make install DESTDIR=/app"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://github.com/libfuse/libfuse.git",
+ "branch": "fuse_2_9_bugfix"
+ }
+ ]
+ },
+ {
+ "name": "ostree",
+ "buildsystem": "autotools",
+ "config-opts": [
+ "--disable-rofiles-fuse"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://github.com/ostreedev/ostree.git",
+ "branch": "main"
+ }
+ ]
+ },
+ {
+ "name": "pyparsing",
+ "buildsystem": "simple",
+ "build-commands": [
+ "pip3 install --prefix=/app --no-deps ./pyparsing-*.whl"
+ ],
+ "sources": [
+ {
+ "type": "file",
+ "url": "https://files.pythonhosted.org/packages/8a/bb/488841f56197b13700afd5658fc279a2025a39e22449b7cf29864669b15d/pyparsing-2.4.7-py2.py3-none-any.whl",
+ "sha256": "ef9d7589ef3c200abe66653d3f1ab1033c3c419ae9b9bdb1240a85b024efc88b"
+ }
+ ]
+ },
+ {
+ "name": "flatpak",
+ "buildsystem": "autotools",
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://github.com/flatpak/flatpak.git",
+ "branch": "main"
+ }
+ ]
+ },
+ {
+ "buildsystem": "meson",
+ "builddir": true,
+ "name": "gnome-software",
+ "config-opts": [
+ "--libdir=/app/lib",
+ "-Dpackagekit=false",
+ "-Dpackagekit_autoremove=false",
+ "-Dsoup2=true",
+ "-Dfwupd=false",
+ "-Dflatpak=true",
+ "-Dmalcontent=false",
+ "-Dgudev=false",
+ "-Dgtk_doc=false",
+ "-Dprofile=Devel"
+ ],
+ "sources": [
+ {
+ "type": "git",
+ "url": "https://gitlab.gnome.org/GNOME/gnome-software.git",
+ "branch": "main"
+ }
+ ]
+ }
+ ]
+}