summaryrefslogtreecommitdiffstats
path: root/lib/tools/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tools/meson.build')
-rw-r--r--lib/tools/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/tools/meson.build b/lib/tools/meson.build
new file mode 100644
index 0000000..6844775
--- /dev/null
+++ b/lib/tools/meson.build
@@ -0,0 +1,24 @@
+# Test program to profile performance of the key-colors functions
+executable(
+ 'profile-key-colors',
+ sources : [
+ 'profile-key-colors.c',
+ '../gs-key-colors.c',
+ '../gs-key-colors.h',
+ ],
+ include_directories : [
+ include_directories('..'),
+ include_directories('../..'),
+ ],
+ dependencies : [
+ glib,
+ gtk,
+ gdk_pixbuf,
+ libm,
+ ],
+ c_args : [
+ '-Wall',
+ '-Wextra',
+ ],
+ install: false,
+)