summaryrefslogtreecommitdiffstats
path: root/HACKING
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:59:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:59:44 +0000
commitfb31765cbe33890f325a87015507364156741321 (patch)
tree0c5cd12aee0a0a6a6e2d542520df5846859bd40d /HACKING
parentInitial commit. (diff)
downloadgnome-system-monitor-fb31765cbe33890f325a87015507364156741321.tar.xz
gnome-system-monitor-fb31765cbe33890f325a87015507364156741321.zip
Adding upstream version 42.0.upstream/42.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'HACKING')
-rw-r--r--HACKING30
1 files changed, 30 insertions, 0 deletions
diff --git a/HACKING b/HACKING
new file mode 100644
index 0000000..726141a
--- /dev/null
+++ b/HACKING
@@ -0,0 +1,30 @@
+# Dependencies - can be found in meson.build
+sudo apt-get install meson gettext appstream-util itstool libglibmm-2.4-dev libgtkmm-3.0-dev libgtop2-dev librsvg2-dev libxml2-dev libsystemd-dev
+
+# Meson
+
+## configure creates the build directory
+meson build --prefix /home/benoit/gnome
+
+## build - compiles the source
+ninja -C build
+
+## install - required to be able to run the application
+ninja -C build install
+
+## clean - removes built files to do a clean build
+ninja -C build -t clean
+
+## start from scratch
+rm -rf build
+
+
+
+
+# Old
+
+## configure
+./autogen.sh --prefix=/home/benoit/gnome
+
+## build
+make