summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:59:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:59:45 +0000
commitd280ed290c280cce534f453457ee783266215539 (patch)
tree35eeee36f5bd7025bf465d496a1850a08386a5b7 /debian/rules
parentAdding upstream version 42.0. (diff)
downloadgnome-system-monitor-debian.tar.xz
gnome-system-monitor-debian.zip
Adding debian version 42.0-2.debian/42.0-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2aa8383
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+CONFFLAGS = -Dsystemd=true
+else
+CONFFLAGS = -Dsystemd=false
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- $(CONFFLAGS)
+
+execute_after_dh_auto_build:
+ docbook-to-man debian/gnome-system-monitor.sgml \
+ > debian/gnome-system-monitor.1
+
+execute_before_dh_auto_clean:
+ rm -f debian/gnome-system-monitor.1
+
+override_dh_installchangelogs:
+ dh_installchangelogs -XChangeLog