summaryrefslogtreecommitdiffstats
path: root/scripts/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/meson.build')
-rw-r--r--scripts/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/scripts/meson.build b/scripts/meson.build
new file mode 100644
index 0000000..cb2213c
--- /dev/null
+++ b/scripts/meson.build
@@ -0,0 +1,17 @@
+commands = [
+ 'renice',
+ 'kill',
+ 'taskset',
+]
+
+foreach command : commands
+ executable('gsm-' + command,
+ 'gsm_execute_helper.c',
+ dependencies: [
+ glib,
+ ],
+ c_args: '-DCOMMAND="@0@"'.format(command),
+ install: true,
+ install_dir: join_paths(get_option('libexecdir'), meson.project_name())
+ )
+endforeach