summaryrefslogtreecommitdiffstats
path: root/Makefile.meson
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.meson')
-rw-r--r--Makefile.meson51
1 files changed, 51 insertions, 0 deletions
diff --git a/Makefile.meson b/Makefile.meson
new file mode 100644
index 0000000..73a4edd
--- /dev/null
+++ b/Makefile.meson
@@ -0,0 +1,51 @@
+# Copyright © 2019 Christian Persch
+#
+# This programme is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at your
+# option) any later version.
+#
+# This programme is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+# See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this programme. If not, see <https://www.gnu.org/licenses/>.
+
+srcdir=@srcdir@
+builddir=@builddir@
+
+#
+
+NTHREADS = 1
+NJOBS = -j$(NTHREADS)
+NINJA = ninja $(NJOBS)
+
+MESON = meson
+
+#
+
+all:
+ $(NINJA)
+
+check:
+ MESON_TESTTHREADS=$(NTHREADS) $(NINJA) test
+
+clean:
+ $(NINJA) clean
+
+coverage:
+ $(NINJA) coverage
+
+install:
+ $(NINJA) install
+
+uninstall:
+ $(NINJA) uninstall
+
+dist:
+ $(MESON) dist --no-tests
+
+distcheck:
+ $(MESON) dist