summaryrefslogtreecommitdiffstats
path: root/man/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
commitcca66b9ec4e494c1d919bff0f71a820d8afab1fa (patch)
tree146f39ded1c938019e1ed42d30923c2ac9e86789 /man/CMakeLists.txt
parentInitial commit. (diff)
downloadinkscape-cca66b9ec4e494c1d919bff0f71a820d8afab1fa.tar.xz
inkscape-cca66b9ec4e494c1d919bff0f71a820d8afab1fa.zip
Adding upstream version 1.2.2.upstream/1.2.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'man/CMakeLists.txt')
-rw-r--r--man/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
new file mode 100644
index 0000000..f467560
--- /dev/null
+++ b/man/CMakeLists.txt
@@ -0,0 +1,26 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+# Load AUTHORS file contents into $INKSCAPE_AUTHORS
+file(READ ${CMAKE_SOURCE_DIR}/AUTHORS content)
+string(REGEX REPLACE "^([^\n#]+)\n" "\\1;\n" content_list "${content}")
+join(INKSCAPE_AUTHORS "," "${content_list}")
+
+
+file(GLOB podfiles *.pod.in)
+foreach(podfile ${podfiles})
+ get_filename_component(basename ${podfile} NAME)
+ string(REPLACE ".pod.in" "" basename ${basename})
+
+ set(POD_IN ${CMAKE_CURRENT_SOURCE_DIR}/${basename}.pod.in)
+ set(POD_OUT ${CMAKE_CURRENT_BINARY_DIR}/${basename}.pod)
+
+ configure_file(${POD_IN} ${POD_OUT})
+
+ if(basename MATCHES "^inkscape")
+ pod2man(${POD_OUT} ${INKSCAPE_VERSION} 1 "Inkscape Commands Manual")
+ elseif(basename MATCHES "^inkview")
+ pod2man(${POD_OUT} ${INKSCAPE_VERSION} 1 "Inkview Commands Manual")
+ else()
+ message(WARNING "unexpected podfile: ${podfile}")
+ endif()
+endforeach()