summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/adaptagrams/libavoid/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
commitcca66b9ec4e494c1d919bff0f71a820d8afab1fa (patch)
tree146f39ded1c938019e1ed42d30923c2ac9e86789 /src/3rdparty/adaptagrams/libavoid/Makefile.am
parentInitial commit. (diff)
downloadinkscape-cca66b9ec4e494c1d919bff0f71a820d8afab1fa.tar.xz
inkscape-cca66b9ec4e494c1d919bff0f71a820d8afab1fa.zip
Adding upstream version 1.2.2.upstream/1.2.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/3rdparty/adaptagrams/libavoid/Makefile.am')
-rw-r--r--src/3rdparty/adaptagrams/libavoid/Makefile.am91
1 files changed, 91 insertions, 0 deletions
diff --git a/src/3rdparty/adaptagrams/libavoid/Makefile.am b/src/3rdparty/adaptagrams/libavoid/Makefile.am
new file mode 100644
index 0000000..837dacb
--- /dev/null
+++ b/src/3rdparty/adaptagrams/libavoid/Makefile.am
@@ -0,0 +1,91 @@
+EXTRA_DIST=libavoid.pc.in
+
+lib_LTLIBRARIES = libavoid.la
+libavoid_la_CPPFLAGS = -I$(top_srcdir) -I$(includedir)/libavoid -fPIC
+libavoid_la_LDFLAGS = -no-undefined
+
+libavoid_la_SOURCES = connectionpin.cpp \
+ connector.cpp \
+ connend.cpp \
+ geometry.cpp \
+ geomtypes.cpp \
+ graph.cpp \
+ junction.cpp \
+ makepath.cpp \
+ obstacle.cpp \
+ orthogonal.cpp \
+ router.cpp \
+ shape.cpp \
+ timer.cpp \
+ vertices.cpp \
+ viscluster.cpp \
+ visibility.cpp \
+ vpsc.cpp \
+ hyperedge.cpp \
+ hyperedgeimprover.cpp \
+ mtst.cpp \
+ hyperedgetree.cpp \
+ scanline.cpp \
+ actioninfo.cpp \
+ assertions.h \
+ connector.h \
+ connectionpin.h \
+ connend.h \
+ debug.h \
+ geometry.h \
+ geomtypes.h \
+ graph.h \
+ junction.h \
+ libavoid.h \
+ makepath.h \
+ obstacle.h \
+ orthogonal.h \
+ router.h \
+ shape.h \
+ timer.h \
+ vertices.h \
+ viscluster.h \
+ visibility.h \
+ hyperedge.h \
+ mtst.h \
+ hyperedgetree.h \
+ scanline.h \
+ actioninfo.h \
+ vpsc.h \
+ debughandler.h
+
+libavoidincludedir = $(includedir)/libavoid
+libavoidinclude_HEADERS = assertions.h \
+ connector.h \
+ connectionpin.h \
+ connend.h \
+ debug.h \
+ dllexport.h \
+ geometry.h \
+ geomtypes.h \
+ graph.h \
+ junction.h \
+ libavoid.h \
+ makepath.h \
+ obstacle.h \
+ orthogonal.h \
+ router.h \
+ shape.h \
+ timer.h \
+ vertices.h \
+ viscluster.h \
+ visibility.h \
+ hyperedge.h \
+ hyperedgeimprover.h \
+ mtst.h \
+ hyperedgetree.h \
+ scanline.h \
+ actioninfo.h \
+ vpsc.h \
+ debughandler.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libavoid.pc
+
+SUBDIRS = . tests
+