summaryrefslogtreecommitdiffstats
path: root/packaging/macos/jhb/etc/modulesets/jhb/patches
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/macos/jhb/etc/modulesets/jhb/patches')
-rw-r--r--packaging/macos/jhb/etc/modulesets/jhb/patches/libtool-apple-sort.patch38
-rw-r--r--packaging/macos/jhb/etc/modulesets/jhb/patches/vasnprintf.patch11
2 files changed, 49 insertions, 0 deletions
diff --git a/packaging/macos/jhb/etc/modulesets/jhb/patches/libtool-apple-sort.patch b/packaging/macos/jhb/etc/modulesets/jhb/patches/libtool-apple-sort.patch
new file mode 100644
index 0000000..8c880ef
--- /dev/null
+++ b/packaging/macos/jhb/etc/modulesets/jhb/patches/libtool-apple-sort.patch
@@ -0,0 +1,38 @@
+--- a/Makefile.am 2015-01-20 07:34:33.000000000 -0800
++++ b/Makefile.am 2021-11-12 10:18:23.000000000 -0800
+@@ -416,8 +416,8 @@
+ # files created in the build tree, so instead we regenerate the
+ # manual pages if the sources for the build-tree files we want to
+ # run have changed.
+-$(libtool_1): $(ltmain_sh)
+- $(AM_V_GEN)$(update_mans) --help-option=--help-all libtool
++#$(libtool_1): $(ltmain_sh)
++# $(AM_V_GEN)$(update_mans) --help-option=--help-all libtool
+ $(libtoolize_1): $(libtoolize_in)
+ $(AM_V_GEN)$(update_mans) libtoolize
+
+--- s/Makefile.in 2015-02-15 08:14:14.000000000 -0800
++++ b/Makefile.in 2021-11-12 10:26:26.000000000 -0800
+@@ -2324,8 +2324,8 @@
+ # files created in the build tree, so instead we regenerate the
+ # manual pages if the sources for the build-tree files we want to
+ # run have changed.
+-$(libtool_1): $(ltmain_sh)
+- $(AM_V_GEN)$(update_mans) --help-option=--help-all libtool
++#$(libtool_1): $(ltmain_sh)
++# $(AM_V_GEN)$(update_mans) --help-option=--help-all libtool
+ $(libtoolize_1): $(libtoolize_in)
+ $(AM_V_GEN)$(update_mans) libtoolize
+
+--- a/build-aux/ltmain.in 2015-02-06 04:57:56.000000000 -0800
++++ b/build-aux/ltmain.in 2021-11-08 14:58:33.000000000 -0800
+@@ -3188,7 +3188,7 @@
+ if test yes = "$lock_old_archive_extraction"; then
+ $opt_dry_run || rm -f "$lockfile"
+ fi
+- if ($AR t "$f_ex_an_ar_oldlib" | sort | sort -uc >/dev/null 2>&1); then
++ if ($AR t "$f_ex_an_ar_oldlib" | sort -u | sort -c >/dev/null 2>&1); then
+ :
+ else
+ func_fatal_error "object name conflicts in archive: $f_ex_an_ar_dir/$f_ex_an_ar_oldlib"
+
diff --git a/packaging/macos/jhb/etc/modulesets/jhb/patches/vasnprintf.patch b/packaging/macos/jhb/etc/modulesets/jhb/patches/vasnprintf.patch
new file mode 100644
index 0000000..995e1e3
--- /dev/null
+++ b/packaging/macos/jhb/etc/modulesets/jhb/patches/vasnprintf.patch
@@ -0,0 +1,11 @@
+--- a/lib/vasnprintf.c 2017-09-29 11:10:29.000000000 +0200
++++ b/lib/vasnprintf.c 2017-09-29 11:15:06.000000000 +0200
+@@ -4858,7 +4858,7 @@
+ #endif
+ *fbp = dp->conversion;
+ #if USE_SNPRINTF
+-# if !(((__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) && !defined __UCLIBC__) || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
++# if !(((__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) && !defined __UCLIBC__) || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__) || defined __APPLE__)
+ fbp[1] = '%';
+ fbp[2] = 'n';
+ fbp[3] = '\0';